UNIVERSITY OF NAIROBI.

AUTOCAD 2011 LEARNERS’ MANUAL.

PROJECT CODE: GON 01/2012.

A project submitted in partial fulfillment of the requirements for the award of the degree of Bachelor of Science in Mechanical and Manufacturing Engineering.

SUPERVISOR

ENG. GEORGE ODUWO NYANGASI

AUTHORS

MUGAMBI GEORGE MUNENE - F18/1856/2007
WANJALA WAFULA FELIX - F18/9243/2005

SCHOOL OF ENGINEERING
DEPARTMENT OF MECHANICAL AND MANUFACTURING ENGINEERING
DECLARATION.

AUTHORS.

We, the undersigned hereby declare that this final year undergraduate project is our original work and has not been presented for a degree in any other university.

…………………………
Mugambi George Munene- F18/1856/2007

…………………………
Date.

…………………………

…………………………
Date.

SUPERVISOR.

This project has been submitted for examination with my approval as University Supervisor.

…………………………
Eng. George O. Nyangasi.

…………………………
Date.
ACKNOWLEDGEMENT.

We are deeply indebted to engineer George Oduwo Nyangasi for his powerful inspiration, competent instruction, careful direction and gentle correction in the process of our research and documentation of AutoCAD 2011 learners manual. Eng. Nyangasi made us realize one fact of life: **that the obstacle is the way.** From the outset, he gave us challenging assignments carefully designed to imbue us with an open mind since AutoCAD itself is a wide software.

Our appreciation further goes out to the esteemed engineers at the Numerical Machining Complex Limited. Thanks to the Research and Development Engineer (Eng.Thubi) and the Production Planning Engineer (Eng. Langat) who’s ESA initiated lecture on 26th February 2012 at the University of Nairobi fuelled our passion to compile this concise manual for the benefit of the beginner. Asking them whether we would visit their premises in May 2012, they received us with open hands and the insight we received on the Design Softwares was life changing at the least.

We can’t forget our classmates Godfrey Momanyi and Davidson Mogaka who prevailed upon us to realize that the project we were about to undertake was challenging. Nonetheless they emerged as our greatest motivators and we looked to them for inspiration and reassurance whenever things seemed to reach a dead end.

Our unequivocal gratitude is hereby expressed to the administration of the University of Nairobi in general and specifically to the Department of Mechanical Engineering whose able leadership under Prof. Stephen M. Mutuli has set up an environment rich with technology and serenity. These factors combined made seemingly mountainous challenges look like small inconveniences.

Our appreciation for our parents cannot be overemphasized. They have stood with us all along beginning at our zero time, and even though their support in this endeavor was anticipated, it was all we could have looked forward to.

Finally and most crucial to us, we give thanks to God. You replenished our strength and determination, and assured us of your breath of life by the break of each day as we hoped to see the completion of this project. To this point, it is by your power. All glory to you now and forever.
DEDICATION.

Mugambi G. Munene.

I dedicate this project to my late mum Hellen K. Peter. Through you, God accorded me presence in the world. I pray that through me, He will accomplish that which He would have accomplished through you.

Wanjala Wafula Felix.
I dedicate this project to my family. Your support has been of enormous help and every single word has inspired me all along. God bless.
ABSTRACT

The aim of this project was to create a learners’ manual for AutoCAD 2011 to act as a guide for beginners as well as a reliable reference for users with basic AutoCAD understanding. It was intended to teach the beginner from simple 2D drawings to complex 3D modeling.

In doing this we used simple and interactive language that make AutoCAD both simple to understand and interesting to learn.

Our decision to write this manual was inspired by a survey indicating that a good number of former graduates missed out on job opportunities because of their lack of good mastery of AutoCAD. We were convinced that AutoCAD is a necessary tool for every engineer, because engineers traditionally communicate their ideas through drawings. And as a matter of fact, it would be very difficult to fabricate anything functional without accurate working drawings.

In coming up with this manual we embarked on intensive research and liaison. We carried out in depth inquest into the relevant areas to include in the manual and their importance to the learner. This we did by interviewing users in industry most prominent among whom, were the engineers at the Numerical Machining Complex Ltd namely, Eng. Thubi, Eng. Mugambi and Eng. Musuko among others.

To gain expertise and competence as drafters in our individual capacity, we entered into apprenticeship with former graduates who have done extensive work in AutoCAD with a special to 2010/2011 AutoCAD manual. Further we made use of texts in AutoCAD written by instructors with immense experience in AutoCAD and drafting standards as indicated in our references section. The internet was also extremely useful to us notably: www.MyCADsite.com especially in the area of 3D modeling.

Through these varied methods of self learning and improvement, we were able to identify the areas most crucial to a beginner, and the challenges that frustrate them when venturing into AutoCAD.

The Learners’ Manual, which is part of our results is the first appendix to this report. It was designed with a clear objective of making it easy to learn AutoCAD for a beginner.

The chapters and content of the manual have been ordered in such a way that the leaner gets introduced to the basic concepts before the complex. For example chapters 1 to 2 deal with AutoCAD window and file handling. Chapters 3 and 4 deal with coordinate systems, navigation tools, draw and modify commands. Chapter 6 is a covers sample drawings to review the contents of chapter 1 to 5 and introduction to 3D work in chapter 7. Chapter 7 covers 3D drawings and assembly conclusively. Chapter 8 covers surface and mesh modeling while chapter 9 concludes with plotting and printing of drawings.
This report is a brief description of the methods we used to study AutoCAD and how we used that knowledge to make AutoCAD useful to undergraduate and recently graduated engineers. It starts from the literature review in chapter 1. In chapter 2 we cover the objectives and general introduction to AutoCAD as drafting software. Chapter 3 covers the scope and methods of study and compiling the contents of the learners’ manual. **Our final result was the manual and the sample drawings in appendix 1 and 2 respectively.**

This manual was an instant success. Many final year students who had a chance to see the draft before publication requested us to start a class of AutoCAD after their final exams. Masters students in Energy Management congratulated us for meticulously covering the essentials of AutoCAD and were amazed that certain 3D models could be drawn with the software. Ultimately, we believe this manual will be very useful to any student who is interested in mastering AutoCAD.
Table of Contents

TITLE .......................................................................................................................... i
DECLARATION .......................................................................................................... ii
ACKNOWLEDGEMENT ........................................................................................... iii
DEDICATION ........................................................................................................... iv
ABSTRACT ............................................................................................................... v

1 LITERATURE REVIEW ......................................................................................... 1
  1.1. CAD and CAM .................................................................................................. 1
      1.1.1. THE ORIGINS OF CAD/CAM ............................................................... 1
  1.2. The Beginners problem ................................................................................... 3
  1.3. Previous projects ........................................................................................... 3
  1.4. AutoCAD Help ................................................................................................ 3
  1.5. 2D VERSUS 3D .............................................................................................. 4
      1.5.1. COMPARISON BETWEEN THE 2D CAD METHOD AND THE 3D MODELING METHOD. .............................................................. 5
  1.6. Drawing standards ........................................................................................ 7
      1.6.1. BS 308 versus BS 8888 ...................................................................... 8
      1.6.2. About BS 8888 .................................................................................. 8
      1.6.3. What does BS 8888 mean in practice? ................................................. 9
  1.7. Hardware Requirements for AutoCAD 2011 ................................................. 10
  1.8. Evolution of AutoCAD .................................................................................. 10
  1.9. Vision 2030 .................................................................................................. 11
  1.10. AutoCAD versus other Autodesk products ................................................. 12
      1.11. The AutoCAD design flowchart ............................................................... 12

2 INTRODUCTION .................................................................................................... 15
  2.1. Objectives ..................................................................................................... 15
  2.2. Introduction .................................................................................................. 15
  2.3. Chain of distribution and users ..................................................................... 15

3 METHODS AND SCOPE OF STUDY ................................................................... 17
  3.1. SCOPE OF STUDY ...................................................................................... 17
      3.1.1. Workspaces ....................................................................................... 17
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1.2</td>
<td>Drawing Standards</td>
<td>17</td>
</tr>
<tr>
<td>3.1.3</td>
<td>The Ribbon</td>
<td>19</td>
</tr>
<tr>
<td>3.1.4</td>
<td>The Command Window</td>
<td>20</td>
</tr>
<tr>
<td>3.1.5</td>
<td>Commands</td>
<td>20</td>
</tr>
<tr>
<td>3.1.6</td>
<td>Visual styles</td>
<td>20</td>
</tr>
<tr>
<td>3.1.7</td>
<td>Layers</td>
<td>21</td>
</tr>
<tr>
<td>3.1.8</td>
<td>Rendering and Assignment of Materials</td>
<td>21</td>
</tr>
<tr>
<td>3.1.9</td>
<td>User Coordinate System (UCS)</td>
<td>21</td>
</tr>
<tr>
<td>3.1.10</td>
<td>Assembly Drawing</td>
<td>22</td>
</tr>
<tr>
<td>3.2</td>
<td>DATA COLLECTION</td>
<td>22</td>
</tr>
<tr>
<td>3.2.1</td>
<td>Learning Path</td>
<td>22</td>
</tr>
<tr>
<td>3.3</td>
<td>ORGANIZATION OF THE LEARNERS MANUAL</td>
<td>23</td>
</tr>
<tr>
<td>4.</td>
<td>RESULTS</td>
<td>25</td>
</tr>
<tr>
<td>4.1</td>
<td>AutoCAD 2011 Learners Manual</td>
<td>25</td>
</tr>
<tr>
<td>4.2</td>
<td>Sample Drawings</td>
<td>26</td>
</tr>
<tr>
<td>5.</td>
<td>CONCLUSION</td>
<td>27</td>
</tr>
<tr>
<td>REFERENCES</td>
<td></td>
<td>27</td>
</tr>
<tr>
<td>APPENDIX 1</td>
<td></td>
<td>28</td>
</tr>
<tr>
<td>APPENDIX 2</td>
<td></td>
<td>94</td>
</tr>
</tbody>
</table>
CHAPTER 1

1 LITERATURE REVIEW.

1.1. CAD and CAM.

Computer-aided design (CAD) and computer-aided manufacturing (CAM) are a pair of often interdependent industrial computer applications that have greatly influenced the chain of processes between the initial design and the final realization of a product. Many would add to this duo a third technology, computer-aided engineering (CAE). Ongoing refinements in CAD/CAM systems continue to save manufacturers tens of millions of dollars in time and resources over non-computerized methods. As a consequence, CAD and CAM technologies are responsible for massive gains in both productivity and quality, particularly since the 1980s. For some purposes CAD and CAM methods can be used exclusively of one another, and in general, CAD is used more commonly than CAM.

CAD involves creating computer models defined by geometrical parameters. These models typically appear on a computer monitor as a three-dimensional representation of a part or a system of parts, which can be readily altered by changing relevant parameters. CAD systems enable designers to view objects under a wide variety of representations and to test these objects by simulating real-world conditions.

CAM picks up where CAD leaves off by using geometrical design data to control automated machinery. CAM systems are associated with computer numerical control (CNC) or direct numerical control (DNC) systems. These systems differ from older forms of numerical control (NC) in that geometrical data is encoded mechanically. Since both CAD and CAM use computer-based methods for encoding geometrical data, it is possible for the processes of design and manufacture to be highly integrated.

1.1.1. THE ORIGINS OF CAD/CAM

CAD had its origins in three separate sources, which also serve to highlight the basic operations that CAD systems provide. The first of these sources resulted from attempts to automate the drafting process. These developments were pioneered by the General Motors Research Laboratories in the early 1960s. One of the important time-saving advantages of computer modeling over traditional drafting methods is that the former can be quickly corrected or
manipulated by changing a model's parameters. The second source of CAD's origins was in the testing of designs by simulation. The use of computer modeling to test products was pioneered by high-tech industries like aerospace and semiconductors. The third influence on CAD's development came from efforts to facilitate the flow from the design process to the manufacturing process using numerical control (NC) technologies, the use of which was widespread in many applications by the mid-1960s. It was this source that resulted in the linkage between CAD and CAM. One of the most important trends in CAD/CAM technologies is the ever tighter integration between the design and manufacturing stages of CAD/CAM-based production processes.

Numerical control (NC) of automated machinery was developed in the early 1950s and thus preceded the use of computerized control by several years. Like CAM, NC technologies made use of codified geometrical data to control the operations of a machine. The data was encoded by punch holes on a paper tape that was fed through a reader, essentially the same mechanism as that on a player piano. Once the control tape was produced, it offered a reliable means to replace the skilled machinists that had previously operated such machines. From the firm's point of view, the drawback of the old NC technologies was the difficulty in converting the design for a three-dimensional object into holes on a tape. This required the services of a tape encoding specialist. Since this specialist was required to work without any significant visual feedback, work was essentially trial and error and could only be tested in the actual production process. The tape encoder had to account for a large number of variables, including optimal feed rates and cutting speeds, the angle at which the tool should contact the part, and so on. Given the considerable time and expense involved in NC technologies, it was only economically viable when a large number of parts were to be produced.

The development of CAD and CAM and particularly the linkage between the two overcame these problems by enabling the design and manufacture of a part to be undertaken using the same system of encoding geometrical data. This eliminated the need for a tape encoding specialist and greatly shortened the time between design and manufacture. CAD/CAM thus greatly expanded the scope of production processes with which automated machinery could be economically used. Just as important, CAD/CAM gave the designer much more direct control over the production process, creating the possibility of completely integrated design and manufacturing processes.
1.2. The Beginners problem.
Even with its power and flexibility, the microcomputer-based CADD (Computer Aided Design/Drafting) software is more difficult to learn than the use of traditional tools. The learner may master the user interface, but then get lost when it comes to the sequence of commands to execute a given task. Further, the learner may know how to draw the different geometric figures, yet fail to unite them into a complete design.

Though the engineer may have the strength of ideas, yet the weakness of not being able to share them with colleagues and clients overshadows them.

1.3. Previous projects.
There is a lot of literature on AutoCAD written by experienced AutoCAD users. At the Department of Mechanical Engineering at the University of Nairobi, there has been modest effort made to come up with a text that could solve the problem of poor mastery of AutoCAD and other design softwares notably the year 2004 and 2011.

The university has supplemented these efforts by procuring licenses for the unlimited use of Autodesk softwares (AutoCAD and Inventor) by her students. However the truth is that, though worthwhile, these efforts seem not to have yielded the desired fruits.

One contributing factor is that a very long text which has very little visual incentive puts off the student. Second if the student sits in front of the computer and tries the commands without a convincing introduction, they become very frustrated when it becomes clear that they cannot make more than several moves without getting stuck. This leaves the student in a sorry state, especially when they have to graduate having only one skill; manual drawing.

The problem is that, the CAD softwares have so revolutionized the industry that manual drawing is finding less and less use. This is not to mean that manual drawing has no place. The most important thing however is that with population explosion in our country and the need to cut down on manufacturing costs while maintaining high efficiency in production and competition, no industry wants to lag behind. Moreover, CAD eliminates waste by ensuring that all important design parameters of the product can be studied on the computer screen before proceeding to fabrication.

1.4. AutoCAD Help.
It is possible to learn AutoCAD from the start to mastery level without having to attend a class. The problem is how?

With internet connection the learner can type any query on the AutoCAD help facility at the top right corner of the screen and receive answers from Autodesk directly. This poses another problem; that since AutoCAD is such a wide software, it would be inconceivable to learn it all by way of typing queries and waiting for answers.
Therefore, the easiest way to learn AutoCAD is to attend introductory classes, done by an experienced user and then exploring the software to master it. The reason for this is because having reached intermediate mastery of commands, advancing becomes easy since the way commands are issued is related whether for the simple or complex tasks.

Further, most of the commands that the learner needs are displayed there on the AutoCAD window inform of the ribbon and as the user clicks on them, the command window at the bottom of the window gives prompts of what could be done next.

1.5. 2D VERSUS 3D.

Here we will use the steam engine for illustration.
Understanding the fundamental differences between 2D drafting and 3D modeling may be necessary when choosing the area in which to specialize. This is because with the apparent CAD/CAM interface both become viable independently. Remember when using CAM the most important thing is to learn accurate entry of coordinates.
A comparison between the two systems may be helpful to those trying to change from 2D drafting to 3D modeling. The drawing below illustrates how 2D drawings are developed for the various parts of a steam engine.

Fig (a): 2D views of a steam engine

Generally, if one is designing an engine using 2D drafting techniques, one must first develop a mental 3D visualization of what the assembled engine will look like, and then draw a front, right side, and top view for each individual part.

If the parts of the engine are drawn in the correct sequence, such as starting with the cylinder and
drawing from the inside out, then the dimensions of each part completed can be extended to the next part to be drawn using extension lines, and in this way, parts that must mate can be drawn to the same dimensions.

For the simple oscillator shown in this example, a total of (17) A4 sheets of parts drawings were required, plus front and top assembly drawings to verify that the parts will fit correctly when assembled, and four front view drawings of the assembled engine with the crankshaft rotated to the 0, 90, 180 and 270 degree positions to check rotating part clearances, piston travel, and head clearances.

So when using 2D drafting techniques, the 3D image shown in the photo at the center of the diagram must first be visualized and conceptualized, and then the 2D drawings for the front, right side, and top views must be developed as flat projections of the 3D visualization. None of the information in the various views in 2D technical drawing has any linkage to another view, so any change to any drawing in 2D has no effect on any other drawing, even though the two drawings may be the front and right side of the same part.

1.5.1. COMPARISON BETWEEN THE 2D CAD METHOD AND THE 3D MODELING METHOD.

For 3D modeling, for many engine builders, the ultimate result of the modeling is to produce a set of 2D drawings that are similar or identical to those shown above which were produced using a 2D CAD program.

Below is the beginning of the 2D drawing part of the 3D program, and when the drawing for each part is finished, there will be the same number of 2D drawings produced by the 3D program as were required with the 2D program.

So the question arises "If a 2D program produces 2D drawings of engine parts, and a 3D program produces 2D drawings of engine parts, then why not just skip the entire "3D modeling" part and simply use the 2D program to make the 2D drawings?"
Once the 3D model has been created (and that is a big ONCE) then it is quick and easy to drag and drop not only the standard three views such as front, right side, and top, but also easy to create the isometric view shown in the upper right side of the sheet.

This process in AutoCAD is facilitated by the use of multiple viewports.

Isometric drawings can also be created using 2D CAD programs, but not nearly as easily as with a 3D modeling. Below is an example of an isometric view created using a 2D CAD program.

Although the isometric views are not dimensioned, and you would never measure a dimension from an isometric view, they are very helpful in forming an overall 3-dimensional image of the part, which otherwise may be difficult to visualize just by viewing the front, side and top views of a part.
1.6. Drawing standards
Drawing standards specify the type of lines that can be used for all applications and the required line thickness. They show Drawing sheet sizes available and their Designations as well as guidelines on text height, spacing and character type that should be used in drawings. Currently in Kenya, the British standard 308 is still applicable and some of its specifications will be provided with this report as an appendix. However it is worthy to note that the British Standards Institute replaced it with BS 8888 as stipulated below. Some of the specifications of standards include the following:

1. Layout of drawings.
   - Drawing Sheets( A1,A2,A4)
   - Title Block( text Character height)
   - Types of Drawing
   - Drawing Formats
2. Scales.
   - Recommended Scales
   - Choice of Scales
3. Lines and Line work.
   - Line thickness

Fig (c): 2D Isometric drawing
Types of lines and their application

4. Lettering and Numerals.
   - Style
   - Character Height
   - Direction of Lettering
   - Location of notes
   - Underlining

5. Systems of Projection.
   - Projection Symbols (first angle, third Angle)

1.6.1. BS 308 versus BS 8888.

In 1927, the British Standards Institute (BSI) introduced a national standard for engineering drawing known as BS 308. This standard was developed and expanded over the next 73 years, until it was finally withdrawn in 2000.

While BSI maintained and developed BS 308 over the years, as a key member of the International Organization for Standardization (ISO), BSI were playing an important part in the development of international (ISO) standards for technical specifications in parallel with this. Many of these international standards were subsequently incorporated as British Standards. By 2000, a full set of British standards for engineering drawing included around 30 ISO standards as well as all three parts of BS 308.

The maintenance of two parallel sets of standards, which duplicated each other in many ways, was hard to justify. It led to confusion among users about which set of standards they should be working to, and about the differences between them. In the second half of 2000, BS 308 was withdrawn, and BSI took the logical and inevitable step of adopting ISO standards in full for engineering documentation. Due to the high level of compatibility between the two sets of standards, this was a relatively smooth transition, but there have been some changes to working practices.

1.6.2. About BS 8888.

In order to make the transition from British to ISO standards possible, BSI produced a new standard to provide a kind of gateway or interface between the user and the ISO system.
This new standard performed three fundamental tasks:

- firstly, it provided a unifying identity for all those ISO standards which relate to Technical Product Specification;
- secondly, it provided an index showing which ISO standards dealt with which aspect of technical product specification (TPS);
- finally, it provided BSI with a platform for providing additional explanation and commentary where this was felt to be useful.

This new standard could have been published as a new version of BS 308, but the nature and content of the standard were so different to BS 308 that BSI decided that it should be given an entirely new name, and BS 8888 came into being. Since its introduction, BS 8888 has been revised four times, and the current version is BS 8888:2008 which was published in November 2008.

Altogether BS 8888 refers ‘normatively’ to over 130 ISO and EN ISO standards (i.e. these must be complied with if documents claim to comply with BS 8888), and informatively to around another 30 (i.e. for information but not mandatory).

1.6.3. What does BS 8888 mean in practice?

There are a number of changes and developments to working practices, many of which would have been introduced through a new version of BS 308 if it had not been withdrawn. Principle changes can be summarized as follows:-:
The standards cover more than just engineering drawing, they cover all aspects of technical product specification, including, for instance, the use of 3D CAD models to define component geometry.

Requirements for drawing borders and title blocks have been formalized and changed in some areas. The comma is to be used as a decimal marker instead of the full stop.

The use of dimensions, size tolerances, datums, geometrical tolerances, edge and surface specifications have been formalized and systematized under the heading of Geometrical Product Specification (GPS).

BS 8888 is now fully consistent with the ISO system.

there is no longer a risk of two different sets of standards.

1.7. Hardware Requirements for AutoCAD 2011.

AutoCAD 2011 is a heavy software. It is therefore only convenient to use when run on a computer that is equally efficient. Following properties might be the minimum for efficient operation.

1. IBM- compatible computer with at least a Pentium 4 or equivalent CPU.
2. 2GB free space for the AutoCAD program files.
3. About 120MB of additional space for sample files and the workspace.
4. Enough free disk space to allow for a windows virtual memory page file that is about 1.5 times the amount of the installed RAM.
5. At least 2GB or more of RAM.
6. High resolution monitor and an up-to-date display card.
7. An SVGA display with a resolution of 1024*768 is fine but in order to gain full advantage of the new 3D features it’s advisable to obtain a 128 MB or greater, open GL-capable, workstation-class graphics card.
8. In order to use a digitizer tablet, one free USB or SERIAL port needs to be available.
9. A DVD reader is needed to install the AutoCAD 2011 software. An internet connection is necessary to take full advantage of the support offerings from Autodesk.

1.8. Evolution of AutoCAD.

Since its initial release in 1982, Autodesk releases new versions of AutoCAD almost yearly. Our manual is meant to train the learner on AutoCAD 2011, yet at the time we were compiling it, AutoCAD 2013 was already out and in use.

So the learner may want to know how to keep pace with the relentless benchmarking. Our answer is that no need to worry. With the DXF file format, it’s easy to share drawings between different versions of AutoCAD.

You define the destination of the drawing during saving operation by clicking on the FILE OF TYPE drop down arrow. The application menu is used to export drawings to other softwares using the DWG file format. To perform the export or import function both the softwares ought to be installed on the same computer or network.
1.9. Vision 2030.

The vision 2030 is built upon and is dependent on three pillars namely: economic, social and political. To succeed along these lines we will need to have excelled technologically, set up industry and multiplied industrial output in order to satisfy the overwhelming needs and wants of the people. The latter requirement inadvertently adds engineering as the fourth pillar if vision 2030 is to be called by its correct name; a realistic dream.

Given the advances of technology around the world, key issue is training our people to gain competence in aligning themselves with the surging technology.

Importantly though efficient operation, maintenance and repair of machines will be crucial. Further, efficient and accurate design of the components to be fabricated on these machines is indispensable.

Mastery of AutoCAD is one among the key aspects that will prepare engineers to be useful in the anticipated new dispensation.
1.10. AutoCAD versus other Autodesk products.

With Auto CAD, an object of any size of true physical size can be represented. AutoCAD can be called a generic software. This means that engineers, architects and drafters will find it very useful for majority of their design work since it provides all the tools needed to execute the tasks at hand. From the palettes panel all symbols, conventions and standards applicable in a particular field are provided. This standardization enhances the sharing of design ideas between the professionals from different fields especially when their input is called upon during projects like construction, machine design and fabrication among others. Autodesk products such as Inventor, AutoCAD mechanical, 3DsMax, Revit, AutoCAD Architecture among others are specialized softwares in the sense that they are suited for people in the particular specified field. For example Inventor is specialized for the design, prototyping and simulation of Mechanical systems and components. The advantage of mastering AutoCAD on the part of a mechanical engineer is that:

- By itself it is enough for all his design and drafting needs.
- By choosing to diversify into the specialized counterparts such as inventor, he will find nothing strange.
- If the mechanical engineer finds himself in a team consisting of professionals using the specialized softwares he is not bound to learn them. The DWG file format facilitates the sharing of designs and ideas between them without having to relearn all the softwares.

1.11. The AutoCAD design flowchart.

The ease or difficulty of using AutoCAD depends on one’s mastery of the following aspects stipulated in the flow chart below.
i. **Workspace:** The most important aspects of the workspaces include the following:
  - The organization of the workspaces.
  - Parts of the workspaces and their use.
  - Tools and their uses.
  - The relationship between the different workspaces and switching from one to the other.
ii. **File Handling:** the different aspects of file handling include:
   - Opening, saving closing.
   - AutoCAD file formats for information sharing and interchange including DWG and DXF.

iii. **Commands and Navigation:**
   - Meaning and nomenclature.
   - Access, use and application.

iv. **Editing and Modification:** No drawing can be completed in one bracket operation. The initial drawing steps are enhanced by editing and modification to the initial drawing whether it’s a surface, a mesh a solid or a 2D line network.

v. **Actual Designs:** This is the final graphical representation of the idea.

vi. **Printing of final geometry:** The final stage of the AutoCAD drawing process is the printing of the drawing on paper.
CHAPTER 2.

2 INTRODUCTION.

2.1. Objectives.

The objectives of our project were as follows:

- To study AutoCAD 2011 at length.
- To develop AutoCAD 2011 Learners Manual with the capacity to teach a beginner from the basics through to complex 3D modeling.

2.2. Introduction.

Before the introduction of CADD (Computer Aided Design/Drafting), the methods used to create engineering graphics were for the better part manual and tiresome. Even though piece meal changes like the drafting machine, improved drawing media and the mechanical drafting pencil boosted the efficiency of the designer, they were not revolutionary. Use of the computer to produce these graphics is revolutionary and \textbf{multiplies the efficiency of the experienced user}.

As a country we are working hard to \textbf{industrialize} in the medium run. Moreover we want to achieve \textbf{the millennium development goals} and attain \textbf{vision 2030} in the short run. In both endeavors engineers bear the ultimate responsibility of designing projects and executing them.

This requires both clarity and accuracy in communication amongst themselves, and with the stakeholders in various capacities. For the smoothness of these processes then, we need our engineers to be able to design and draw using CADD software.

From the preceding backdrop we found the urgent need to come up with a Learners Manual for AutoCAD 2011. The organization of the manual is such that it will take the learner from the simple to the complex. The learner will be able to familiarize with the interface of AutoCAD 2011 before proceeding to issuing simple commands and executing them. That done, he will then proceed to 2D and finally to 3D.

Our ultimate aim is to instruct the learner in 3D drawing. However, taking into account that he may be a beginner with the software or has just a modest knowledge of it, we chose to have a starting point that at the least will be convenient in the specific circumstances of the learner.

2.3. Chain of distribution and users.
AutoCAD dates back from 1982, when it was founded by John Walker. It currently runs exclusively on Microsoft Windows operating systems.

**AutoCAD is a product of Autodesk Corporation** based in Las Vegas in the United States of America. Many other CADD products are produced by Autodesk Inc. together with AutoCAD and include Autodesk Inventor, 3DMax AutoCAD architecture among others.

The main dealers in Africa are based in South Africa who then distribute the products to specific dealers in the respective countries.

Here in Kenya, the authorized dealer is Numerical Machining Complex Ltd. NMC then sells the product to the users who include educational institutions, construction consultants, Mechanical Engineering companies plant designers and infrastructure companies among others.

**Figure (a)** below is a flow diagram of the distribution channel.
CHAPTER 3.

3. METHODS AND SCOPE OF STUDY.

3.1. SCOPE OF STUDY.

3.1.1. Workspaces.

The default workspaces available on AutoCAD include 2D drafting and annotation, 3D modeling, AutoCAD classic and 3D basics. Further, extensive study showed that the user has unlimited power to define their own workspaces and saving them.

This they can do by:
- Switching on or off tool palettes.
- Docking different tool palettes at preferred locations on the window
- Defining their own User Coordinate Systems (UCSs) among other operations.

We found that the concept of workspaces does not mean they are different, but a certain workspace may have several extra or less tool sets than the other. However the underlying drafting principles remain the same and it is possible to:
- Start a drawing in one workspace and finish it in the other just by switching between them using the workspace switching tool.

All details concerning workspaces have been included in appendix 1; the subject of this report.

3.1.2. Drawing Standards.

Standards define the conventions to be used for different aspects of a drawing. All drawing softwares are initially designed to conform to certain laid down standards. In Kenya the drawing standard that is still operational is BS 308. However internationally, this drawing standard has been technically replaced by BS 8888 which was designed in order to conform to the internationally recognized ISO standards.

These standards are set in order to govern information interchange among engineers, technologists and industrial designers around the world. It is with that aspect in place that producers of AutoCAD release the software to the market with standards as part of the package. However the standards manuals themselves are essential for quick referencing.
The conventions for different fields in AutoCAD can be retrieved from the View tab > palettes panel > tool palettes button; see fig (c) below. Clicking on the mechanical option shows the standards in figure (d). Other aspects of standards can be specified by the user of AutoCAD by using the properties panel from the view tab. These include issues like line thicknesses, length of dashes, character heights among others. Alternatively, during the drafting process, right clicking on a line for instance will show the properties tab as part of the options. By selecting it one is able to adjust the parameters according to the laid down standards.

Fig: (c): The standards palette.
3.1.3. The Ribbon.

This is a collection of tool panels representing groups of tools and features where tools to draw, edit, or perform other functions are found. It occurs immediately below the menu bar. The Menu Bar options are also called ribbon tabs. Consequently, clicking on any of the tabs opens a different ribbon; i.e. different tool panels. For instance the home tab, shows such panels as modeling, mesh, draw modify among others. The ribbon facilitates the heads-up drafting style where all the commands needed for any drafting session are right before the user in the form of icons and a simple click of the mouse is all that is needed to activate them.

Figure (a) and (b) below shows the ribbon panels in the default form and with the expanded panels respectively. Mastering the ribbon accords the user agility, speed and convenience.

Fig. (a). The default size of the ribbon panels.
Fig. (b) The ribbon with the expanded panels. Notice the appearance of the push pin at the lower left corner of the panels.

3.1.4. The Command Window.
It’s located just below the drawing area. As commands are typed on the command line, or picked on the ribbon panels, a message is displayed on the command window on what to do next. When any command is issued, the command line may also display a list of options related to that command. By so doing it prompts the user on their next move. Thus it is also known as the command prompt.

3.1.5. Commands.
The user communicates with AutoCAD by using tools and Menu options. These devices invoke AutoCAD commands.

3.1.5.1. What is a command?
It’s a single-word instruction given to AutoCAD telling it to do something such as draw a line (the line tool in the Draw Ribbon Panel) or erase an object (the Erase tool in the Modify Ribbon Panel). Whenever a command is activated by either typing it or selecting a menu option or tool, AutoCAD responds by presenting messages to the user in the Command Window and the Dynamic Input display or by displaying a dialogue box.

By right clicking during the drawing process, a context-sensitive short cut menu is displayed; i.e. if the user is in the middle of a command, this menu displays a list of options specifically related to that command.

3.1.6. Visual styles.
Visual styles become very necessary when we come to the 3D modeling environment. They enhance the view of 3D objects. They include wire frame, conceptual, shaded, and realistic among others.
Without the visual styles it would be an uphill task to manipulate objects in 3D since the network of lines in wire frame (the default visual style) can be confusing to the user.

We need the conceptual visual style for instance to do the following:

- To assemble parts together by enhancing the snapping action.
- To draw objects on the faces of other objects.
- To ascertain the success of such operations as union and subtract.

### 3.1.7. Layers.

Layers are necessary in both 2D and 3D environments when dealing with complex drawings. They help in managing the complexity by making it possible to work on different parts of a drawing at different times. With layers it is possible to do the following:

- Switch off the layers that are not being worked on currently.
- Apply different colors to the different layers to enhance the view.
- Alter individual layer properties independently.

### 3.1.8. Rendering and Assignment of Materials.

Further from the visual styles, it is possible to enhance the view of drawings by giving them a real life appeal. This is done by assigning materials to the objects, mimicking the ones the object would have in real life scenario.

To assign materials then, the first step is to activate the materials browser from the render tab. Once on the browser one can search for the material according to category. Once the desired one is found, it is dragged from the swatch to the tablet.

The procedure of assigning varies between dragging the material on to the object to first clicking on the object then right clicking on the material and then assigning to the selection.

### 3.1.9. User Coordinate System (UCS).

In the lower-left corner of the drawing area there is an L-shaped arrow. This is the UCS icon, which indicates the orientation in the drawing. This icon becomes helpful when working with complex 2D drawings and 3D models. The X and Y arrows indicate the X- and Y-axes of the drawing. The little square at the base of the arrows after launching AutoCAD indicates the *World Coordinate System (WCS)*.

Whenever AutoCAD is launched the default UCS is the WCS. However it is possible and easy to define a new UCS in which the user intends to work in. This is done by going o the
view tab> coordinates panel> Named UCS tool and selecting the preferred orthographic UCS. All procedures of defining and saving UCSs have been covered in appendix 1.

3.1.10. Assembly Drawing.

In appendix 2, the sample drawings range from single parts to assemblies of multiple parts. Drawing a complex 3D system as a single operation is inconceivable or rather it is very difficult. This makes assembly of parts a viable alternative.

Our drawings were assembled by going to the view tab> windows panel> tiles vertically button. This placed the part files vertically on one window the dragging one component to the other part’s file and then moving it to the desired location. The entire procedure is explained in appendix 1 under 3D modeling.

3.2. DATA COLLECTION.

3.2.1. Learning Path.

Learning AutoCAD with a view to draw simple figures is a challenge at the beginning and some people even give up altogether.

Learning it with a view to draw and manage complex 3D objects and subsequently to teach a beginner by way of text and figures is a different story altogether. So on our part we did the best to cover as much as possible.

We did not just try to work by ourselves though, but we sought knowledge with unyielding zeal and practiced regularly. Most of the drawings we came up with are presented with this report as the second appendix.

Below is how we gathered our input:

3.2.1.1. Lectures and Apprenticeships.

In the initial stages we attended regular lectures and one to one discussions with seasoned AutoCAD users among them John Ngungu (a graduate of the department of mechanical engineering) and Eng. Mathenge of Mastermind Tobacco Kenya Ltd.

Issues dealt with included:
• The user interface.
• The difference between the workspaces and navigating in each.
• The commands and how to access them.
• The ribbon and new features of AutoCAD 2011.
• File operations.
• Drawing in 2D and 3D workspaces.

3.2.1.2. Interviews and Forums.
An exhaustive presentation on AutoCAD and Inventor by Engineers Thubi and Langat of Numerical Machining Complex Limited did much to convince us that it was possible to learn and teach AutoCAD.

We later interviewed Engineers Thubi, Musuko and Mugambi of NMC, who took us through the supply chain of Autodesk softwares, the drawing standards and conventions and the difference between the scope of AutoCAD and other specialized softwares such as Inventor.

3.2.1.3. Assignments.
Our supervisor (Eng. Nyangasi) gave us challenging assignments, among them coming up with a visual representation of the Water Supply System of Mechanical engineering building. These put our mastery of 3D to the test and ultimately sharpened them further.

3.2.1.4. Constant Practice.
Through constant practice and drawing as many different types of objects and assemblies as possible, we learnt the best way to come up with complex drawings. This skill made our work of writing the Learners manual easy and faster.

Appendix 2 shows part of our practice work.

3.3. ORGANIZATION OF THE LEARNERS MANUAL.
The manual layout required careful planning in order to achieve the second objective i.e. To develop AutoCAD 2011 Learners Manual with the capacity to teach a beginner from the basics through to complex 3D modeling.

Following methods were used at the chapter and the entire manual level;

i. Orientation to the workspace and drawing environment.
ii. Familiarization with the commands.
iii. Application and execution of the commands.
iv. Sample drawings consisting essentially of guided drawing sessions to entrench the confidence of the learner in navigation.
v. Teaching the simple first and then the complex.
vi. Procedure of plotting and printing.
In AutoCAD we access different commands to perform certain tasks at different times during the drawing process. Therefore it had to be ensured that the sequence of accessing these commands and modification techniques were done according to the order of the chapters in the training manual.

Each chapter in the manual began with a preview of what to expect and ended with a sample drawing developed interactively for absolute benefit of the learner.
CHAPTER 4.

4. RESULTS


The Learners’ Manual which was part of our results is Appendix 1 of this report and covers our second objective in detail.

Coming up with the manual required a wide base of knowledge and teaching methods to ensure that the learner finds it of immense help. It was thus imperative for us to research and consult widely. Previously we have mentioned a number of Engineers and professionals with whom we consulted, sources of our material and our commitment to practice which helped us to test the content before including it in the manual. Just to mention, all illustrative drawings and sketches in the manual are drawn by us on AutoCAD 2011.

The manual is laid out with great attention to detail and accuracy. The following was included in the manual, and we considered it to be the ultimate resource that the learner would require to begin with. It gives them a foundation in a way that would enable them to advance on their own with few problems.

Chapter 1 deals with the AutoCAD window and setting up the workspace in readiness to draw. Chapter 2 is a brief overview of file operations including opening existing files, creating new files, saving files after working on them and saving them with a different name after making changes.

AutoCAD being a precision drafting tool, the issue of coordinate systems and entry of distances with precision was handled independently in chapter 3. Chapter 4 deals with the tools that enhance correct viewing of the model during and after drawing. They include pan, zoom and orbit tools.

Chapter 5 covers all the draw and tools and commands. This was followed by an interactive process of coming of coming up with a sample drawing in chapter six. The sample drawing was used to demonstrate the interface between 2D and 3D drawing. It was intended to give the learner a chance to experience firsthand the use of methods and tools covered in the preceeding chapters.

3D modeling came as our last chapter yet it formed the core of our intention to write the manual. Through investigation, it was the greatest challenge to many students in our department. In chapter seven, it was covered at length including solid, surface and mesh modeling. However
surface and mesh were given just a brief mention, due to the limitations of space as specified in the rules for submitting undergraduate project reports.

4.2. Sample Drawings.
Our first objective was to learn AutoCAD at length. The sample drawings presented in Appendix 2 are a part of what we accomplished in this respect. Having achieved the first objective, we were able to accomplish our second objective with ease.

The sample drawings are presented here as corroborative evidence that this project is our original work and that the described procedures of creating the drawings actually are correct.

Nonetheless, it is notable that there may be more than one way of creating the same object in AutoCAD. For the purpose of beginning however, we recommend that the beginner uses our manual and as they gain experience it would be easier to discover other methods.
CHAPTER 5.

5. CONCLUSION

This report covered the preview of our learning path and study materials in compiling the Learners Manual in the literature review of chapter 1. We explored different materials ranging from text, tutorials and Youtube videos so as get to grips with the finer details of mastering AutoCAD. In chapter 1, we also dealt with the applicable standards at length. We were guided by the fact that there is more to learning AutoCAD than drawing simple figures and lines.

In chapter 2 we outlined our objectives and the chain of supply of AutoCAD.

In chapter 3 we dealt with our scope of study and the methods used to collect data and compile it into a teaching manual.

Chapter 4 is a recap of our objectives and evaluation of how far we were able to achieve them.

The present chapter is a summary of work done in chapters 1 to 4. The manual and the drawings are presented herein as appendix 1 and 2 as evidence that this project was our original work.
REFERENCES

APPENDIX 1.

A project submitted in partial fulfillment of the requirements for the award of the degree of Bachelor of Science in Mechanical and Manufacturing Engineering.

AUTOCAD 2011 LEARNERS MANUAL

BY

MUGAMBI GEORGE MUNENE- F18/1856/2007
WANJALA FELIX WAFULA-F18/9243/2005
# TABLE OF CONTENTS

1. **INTRODUCTION** ........................................................................................................... 31  
   1.1. Launching AutoCAD.............................................................................................. 31  
   1.2. The AutoCAD window........................................................................................... 31  
   1.3. Setting up the Workspace..................................................................................... 32  
   1.4. The canvas/ model Space..................................................................................... 33  

2. **FILE OPERATIONS** .................................................................................................... 38  
   2.1. File Opening, 2.2. File Saving, 2.3. File Closing.  

3. **COORDINATES ENTRY** .............................................................................................. 40  
   3.1. Cartesian Co-ordinate system............................................................................... 40  
   3.2. Polar Coordinate................................................................................................... 40  
   3.3. Absolute and Relative Co-ordinates..................................................................... 40  
   3.4. Dynamic input........................................................................................................ 41  

4. **NAVIGATION TOOLS AND OBJECT DISPLAY** ...................................................... 42  

5. **COMMANDS** .............................................................................................................. 44  
   5.1. Drawing Command Tools .................................................................................... 44  
       5.1.1 Line, 5.1.2 Rectangle, 5.1.3 Polyline, 5.1.4 Circle, 5.1.5 Arc, 5.1.6 Undo & Redo,  
           5.1.7 Polygon, 5.1.8 Spline, 5.1.9 Ellipse.  
   5.2. Modify Command Tools ....................................................................................... 49  
       5.2.1 Erase tool, 5.2.2 Copy tool, 5.2.3 Mirror tool, 5.2.4 Offset tool, 5.2.5 Array tool,  
           5.2.6 Move tool, 5.2.7 Rotate tool, 5.2.8 Scale tool, 5.2.9 Trim and extend tool,  
           5.2.10 Break tool, 5.2.11 Join tool, 5.2.12 Fillet tool.  

6. **SAMPLE DRAWINGS AND DIMENSIONING** ........................................................ 56  
   6.1. Sample Drawing .................................................................................................... 56  
   6.2. Dimensioning ........................................................................................................ 57  
       6.2.1. Linear, 6.2.2. Dimension, 6.2.3. Aligned Dimension, 6.2.4 Radius & Diameter  
           Dimensions, 6.2.5. Angular Dimension, 6.2.6. Leaders, 6.2.7. Dimension Editing.
6.1.1. Setting up the AutoCAD work Area ................................................................. 58

7. 3D MODELLING ........................................................................................................ 66
7.0. 3D Commands ........................................................................................................ 66
7.1. 3D Modeling ............................................................................................................ 67
  7.1.1. Solid primitives (Box, Cylinder, Cone, Sphere, Pyramid, Wedge, Torus),

7.2. 3D Operations ........................................................................................................ 68
  7.2.1. 3D Move, 7.2.2. 3D Rotate, 7.2.3.Align, 7.2.4. 3D Align, 7.2.5. 3D mirror, 7.2.6. 3D
  7.2.7. Array, 7.2.8. Interface checking, 7.2.9.Slice, 7.2.10.Thicken, 7.2.11.Convert to solid,

7.3. Solid Editing .......................................................................................................... 72
  7.3.1. Union, 7.3.2. Subtract, 7.3.3. Intersect, 7.3.4. Imprint Edges, 7.3.5. Fillet Edges,
  7.3.6. Chamfer Edges, 7.3.7. Color Edges, 7.3.8. Copy Edges, 7.3.9. Extrude faces, 7.3.10. Move
  faces, 7.3.10. Offset faces, 7.3.11. Delete faces, 7.3.12. Rotate faces, 7.3.13. Taper faces,
  7.3.20. Layers

8. Mesh and Surface Modeling ...................................................................................... 86
  Smooth More, Smooth Less, Refine Mesh

9. PRINTING AND PLOTTING .................................................................................... 90
8.1. Plotting ..................................................................................................................... 90
8.2. Layout ....................................................................................................................... 93
CHAPTER 1.

1. INTRODUCTION

1.1. Launching AutoCAD

Launching or starting AutoCAD is the process of making the AutoCAD window active on the computer screen. Three ways to do this are as listed below:

1.1.1 Double click on the AutoCAD 2011 icon on the windows desktop.
1.1.2 Right click on the AutoCAD 2011 icon then select open on the pop-up menu.
1.1.3 Click START, go to all programs then select AutoCAD 2011 from the menu

1.2. The AutoCAD window

Once the AutoCAD 2011 window is active, it should appear as shown on the image shown below. However if you look at the upper left hand corner there is a button with the letter (A) written in red. As you will learn later in this chapter, that is called the application menu of the AutoCAD software. Now look at the right of this button. You should be seeing the phrase ‘3D modeling’. This means that the active workspace is 3D modeling. We shall see how you can switch to the other workspaces shortly.
Careful examination of the above workspace would reveal that it is composed of different areas as stipulated below:

1. **Application Menu**
   This provides the user with file options like save, open, print.

2. **Menu bar.**
   The menu bar appears just below the **title bar** of the AutoCAD 2011 window. It has such tabs as home, solid, surface, mesh and view among others for the case of 3D workspace. If you switch to 2D Drafting & Annotation you find other tabs relevant to that workspace. Depending on which tab you are on, you will see a collection of tool icons just below it which are organized into **panels.** The entire collection of tool icons is referred to as the **ribbon.** As a result the tabs on the menu bar are called **ribbon tabs.**

3. **Ribbon**
   This is a collection of tool panels representing groups of tools and features where you will be selecting tools to draw, edit, or perform other functions. It occurs immediately below the menu bar. Clicking on any of the tabs on the menu bar will give you a different ribbon.
The ribbon facilitates **the heads-up drafting style** where all the commands you need for any drafting session are right there before you in form of icons and you can get access to them by a simple click of the mouse.

Figure (a) and (b) below shows the ribbon panel in the default form and with the expanded panels respectively.

**Fig. (a). The default size of the ribbon panels.**

**Fig. (b) The ribbon with the expanded panels.** Notice the appearance of the push pin at the lower left corner of the panels.

In brief, the ribbon provides all the commands you will need using icon tools.

4. **Drawing Area**
   This is a *virtual* sheet or modeling environment where your designs appear. It is a boundless area on which your designs are created on a 1:1 scale regardless of their actual life size. The drawing area is also called the **canvas**. In the default condition, the drawing area will have three icons on display:
   i. The **user coordinate system icon** at the bottom left corner.
   ii. The **cross hairs** or drawing cursor which may be at any position on the screen depending on whether the user has touched the mouse or not.
   iii. The **view cube** at the top right corner. This is very useful in 3D drawing because it facilitates viewing the object from multiple directions.

5. **Quick Access toolbar**
   This includes the basic file-handling functions that you find in virtually all windows application programs. It occurs at the immediate right of the application menu. It carries such functions as workspace switching and title, new file, open file, save and undo among others.

6. **Info Center**
This is AutoCAD’s online help facility. If you are online type a query there in case you get stuck.

7. UCS.
UCS stands for *User Coordinate System*. In the lower-left corner of the drawing area, you see an L-shaped arrow. This is the UCS icon, which tells you your orientation in the drawing. This icon becomes helpful as you start to work with complex 2D drawings and 3D models. The X and Y arrows indicate the X- and Y-axes of your drawing. The little square at the base of the arrows tells you that you’re in what is called the *World Coordinate System (WCS)*.

Whenever you launch AutoCAD you will be in the **world coordinate system (WCS)**. It is the default UCS in which you will be whenever you launch the software. However you have unlimited capacity to define your own UCS save it and retrieve it whenever you want to work in it. We shall explore how to define your own UCS when we handle 3D modeling.

It’s located just below the drawing area. As you type in commands on the command line, or pick commands on the ribbon panels, a message is displayed on the command window telling you what to do next. When you issue any command it may also display a list of **options** related to that command. By so doing it prompts you on your next move. Thus it is also known as the **command prompt**.

The command window and the ribbon complement each other i.e. you can type commands on the command line or click on the ribbon icons. However the command prompts that appear on the command window prevent the user from getting confused.

Figures (a) to (d) below show the sequence of prompts on the command window for the entire process of drawing a line. In (a) the prompt is **command**: This means AutoCAD is waiting for a command. You issue the command by clicking on the **line tool** on the ribbon or typing **line** on the command line and then pressing the enter key. After clicking the line icon on the ribbon, the command window now prompts you to specify the first point as in figure (b).

**Fig (a)**: the command window waiting for a command.

```
Automatic save to C:\Users\george\appdata\local\temp\Drawing1_1_1_5118.sv$ ...
Command:
Command: Specify opposite corner:
Command:
```
Fig (b): the prompt after issuing the line command.

| Command: Specify opposite corner: |
| Command: | |
| Command: | |
| Command: line Specify first point: |

Figure: (c) shows the next prompt after specifying the first point. AutoCAD is saying: **specify next point or [undo]**: Note that this time there is a prompt as well as an option or alternative to the prompt inside the square brackets. To choose the option simply type U and press enter. Recall that above we said that AutoCAD gives you options related to the command being executed currently. For this case, the option was just one but in other cases you will come across, the options may be several. To choose the option of your choice, simply type the first letter of that option and follow the resulting instructions. Remember that, you will find AutoCAD interesting to learn in the initial stages only when you patiently pay attention to the command line and following the instructions. Otherwise it can be quite frustrating.

After clicking on the second point and pressing the enter key, the command window returns to the initial **command**: state. This is a signal that that the first command has been successfully executed and now it’s waiting for further instructions.

Fig (c): the second prompt plus the option.

**NOTE:**

i. The return function of the **enter** key can also be executed using the **space bar**. Use of either depends solely on the convenience of the user.

ii. The **escape key** is used to cancel a command which has already been issued. Therefore if you are in the middle of a command and you press the escape key,
the command line should read command:. Essentially therefore, if you would like to proceed with the previous command, you would have to reissue it.

Fig (d): command line after a command is executed.

9. Status Bar

The status bar is a thin strip of the AutoCAD window found between the command window and the taskbar. To the extreme left it carries the coordinate readout which indicates to the user the current position of the cursor. Towards the right next to the coordinate readout is the drawing aids panel which carries such tools as object snap, object snap tracking, dynamic UCS and polar tracking among others. These aids assist the user in managing snap and tracking actions. They are activated or deactivated by switching them on or off respectively.

To the extreme right of the status bar we find another panel which contains the model and layout tabs, annotation scale and workspace switching tool (gear wheel icon) among others.

10. Command Line

The command line a discussed above is a part of the command window. It provides you with easy access to the commands that are not currently listed on the ribbon panels. Nonetheless if the user finds it convenient, they can type the command even if it’s listed on the ribbon panels.

The command line carries the most current command. Those that have been most recently executed are seen scrolled up on the command window.

Figure below gives the distinction between the command window and the command line.

Fig: (): The difference between command window and command line.
Note the difference between the command on the command line and the one immediately scrolled above. The former is the most current. The latter has already been executed.

1.1. SELECTING THE WORKSPACE.

A workspace is a task-oriented drawing environment oriented in such a way as to provide you with only the tools and interface elements necessary to accomplish the tasks relevant to that environment.

You can switch between workspaces by using the Workspace Switching Tool. You can also customize the workspace the way you want and then save it. It will be appearing on the list of workspaces during switching and you can select it as an option.

Workspace switching tool takes the form of a gear wheel located at the bottom right hand corner of the active window. Clicking on it produces a drop down list of other alternative workspaces. Clicking on either changes the workspace to the selected choice.

Alternatively you can switch the workspace by clicking on the downward arrow besides the name of the current workspace on the quick access toolbar.
CHAPTER 2.

2. FILING AND DATA INPUT.

AutoCAD 2011 file operations are similar to the file operations in any other Windows program. The general file handling commands include file saving, file opening, file closing and printing of drawings.

2.1. OPENING FILES

There are three ways to open a drawing in AutoCAD.

Using Application Menu

- Click on Application Menu> Open
- On the select file dialogue box that appears, browse through the folders in the Look in slot. This enables you to navigate to the folder where you’ve saved your drawing.
- Clicking on a file allows you to look at a preview of the drawing.
- Select OPEN.

Using the Quick Access Toolbar

- Click on File pull down menu> Open
- At the Select file dialogue box, browse through to the folder in the Look in slot.
- Clicking on a file allows you to look at a preview of the drawing.
- Now you can click Open in the select file dialogue box.

Using the command line

- At the command: prompt on the command line, type Open and enter.
- At the Select file dialogue box, browse through to the folder in the Look in slot.
- Clicking on a file allows you to look at a preview of the drawing.
- Select OPEN.

2.2. FILE SAVING

2.2.1 To save a drawing for the first time

The Save Drawing dialogue box appears when you are saving a drawing for the first time. You are the required to navigate through the folders in the save in slot to select the folder in which you want to save your drawing. Type in the file name and then click save.

If you modify a drawing you may wish to save it again but retaining the original template. In this case select save as from the file pull down or the application menu. Give it a name that signifies its current status i.e. taking into account the changes. Click save.
2.2.2 Saving a File as You Work.

It’s a good idea to save your file periodically as you work on it. As with any Windows program, you can save it under its original name by click on the **Save tool on the Quick Access toolbar** or under a different name by choosing **Save As** from the Application menu, thereby creating a new file.

2.2.3 Making Changes.

Coming up with certain drawings may not take place in one pass. Some will require modifications at virtually every stage. Others involve a series of iterative stages before settling on the final copy.

In these circumstances, AutoCAD offers the required flexibility as opposed to manual drawing. To keep track of all the modifications, the **Save As** tool is very essential.

2.3. CLOSING A FILE

Simply click on the X button on the top right corner of the AutoCAD window to close a drawing. A dialogue box appears asking whether to save the changes on the drawing. Select **yes** to save the changes and **no** if you don’t want to effect the changes. However it’s usually a good practice to save your files before closing them.
CHAPTER 3.

3.0. COORDINATES ENTRY.

3.0.1. OVERVIEW.

When a command prompts you for a point, you can use the mouse to specify a point, or you can enter a coordinate value at the command prompt. If the dynamic input is switched on as we already explained under task bar in chapter 1, you can enter coordinate values in tooltips near the cursor.

Two-dimensional coordinates can be entered as either Cartesian (X, Y) or Polar coordinates.

3.1. Cartesian Coordinate System

A Cartesian coordinate system has three axes, X, Y, and Z. When you enter coordinate values, you indicate a point’s distance in units and its direction (+ or -) along the X, Y, and Z axes relative to the coordinate system origin (0,0,0).

In 2D, you specify points on the XY plane, also called the work plane. The X value of a Cartesian coordinate specifies the horizontal distance, and the Y value specifies the vertical distance. The origin point (0,0) indicates where the two axes meet.

3.2. Polar Coordinate System.

Polar coordinates use a distance and an angle to locate a point. How to do that are going to demonstrate in a short while.

3.3. Absolute and Relative Coordinates.

3.3.1. Absolute coordinates

Represents a specific point in the current work plane relative to the origin point (0,0). To enter an absolute coordinate, type the values as a Cartesian coordinate (X,Y) or Polar coordinate (distance, angle).

3.3.2. Relative coordinate

A relative coordinate is a point specified with reference to the last point specified. We emphasize that it is with reference to your last specified point and not to the origin. This is the distinguishing aspect between relative and absolute coordinates. There are two methods to do this:
i. Select your first point. To select the second point precede the coordinates with the @ symbol. For instance if your next point is at 10 absolute units from your first point at an angle of 30, then you specify it as @10<30. To specify using Cartesian coordinates, the procedure is similar. For instance @5, 5 means horizontal (X) displacement is 5 units and vertical displacement is 5 units.

ii. Move the cursor to specify a direction and then enter the distance directly. This method is referred to as direct distance entry.

3.4. Dynamic Input.

When dynamic input is on, tooltips display information near the cursor as it moves. It is called dynamic input because the information moving with the cursor is updated with the motion of the cursor.

If you type the X value and press tab, the X field (box) displays a lock icon, the Y field is active and you can enter its value.

If you type the X value and press enter, the Y value is ignored and AutoCAD interpretes it as direct distance entry. This procedure applies to any other set of fields for instance distance and angle.
CHAPTER 4.

4.0 NAVIGATION TOOLS OBJECT DISPLAY.

4.1. Overview

When drawing in both 2D and 3D, you may wish to:

- Get a closer look (magnify your drawing).
- View hidden details
- Bring the whole drawing into focus.
- View the hidden details of your 3D drawing.

For a, b and c use the zoom and pan tools as follows:

- Zoom in to magnify and zoom out to minimize the size. Zooming out enables you to see the details that are currently spilt out of the screen or make the object smaller in readiness to add details.
- The pan tool allows you to drag your drawing to a convenient location on the screen.
- For d use the orbit tool. It is the tool that enables you to view the objects in your drawing from different angles. It is very essential, when drawing in 3D.

4.2. Accessing the tools.

4.2.1. Zoom

4.2.1.1. To zoom a view with a single click.

- Display a wheel.
- Right-click the wheel and click Steering Wheel Settings.
- In the Steering Wheels Settings dialog box, under Zoom Tool, select Enable Single Click Incremental Zoom.
- Click OK.
- Display one of the Full Navigation Wheels or the mini View Object Wheel.
- Click the Zoom wedge. The magnification of the model is increased and you are zoomed in closer to the model. If you hold down the Shift key while clicking the Zoom wedge, the model is zoomed out or you can hold down the Ctrl key to zoom in.
- Click Close to exit the wheel.

4.2.1.2. To zoom a view in and out by dragging.

- Display the 2D Navigation wheel, one of the Full Navigation wheels, or the mini View Object wheel.
- Click and hold down the Zoom wedge. The cursor changes to the Zoom cursor.
- Drag vertically to zoom in or out.
- Release the button on your mouse to return to the wheel.
NB: The mouse wheel is a very convenient way of zooming in and out.

4.2.2. Pan
4.2.2.1. To pan the drawing with the pan tool.
   i. Display the 2D Navigation wheel, one of the Full Navigation wheels, or the mini View Object wheel.
   ii. Click and hold the Pan wedge. The cursor changes to the Pan cursor.
   iii. Drag to reposition the model.
   iv. Release the button on your pointing device to return to the wheel.

4.2.2.2. To pan using the middle mouse button or the mouse wheel.
   i. Press and hold down the scroll wheel or middle button. The cursor changes to the Pan cursor.
   ii. Drag to reposition the model.
   iii. Release the wheel or button on your mouse.

4.2.3. Orbit
   i. Display one of the View Object or Full Navigation wheels.
   ii. Click and hold down the Orbit wedge. The cursor changes to the Orbit cursor.
   iii. Drag to rotate the model.
   iv. Release the button on your mouse.

NB: To navigate to the zoom, pan or orbit tools, go to:
   a. View tab> navigate panel> zoom or
   b. View tab> navigate panel> pan or
   c. View tab> navigate panel> orbit.

For the orbit, and zoom tools there are different options depending how the user wants to carry out a given operation, for instance constrained orbit or free orbit. The presence of the different options is signified by the presence of a downward arrow on the selection tab. A selection tab with an arrow is called a **flyout** and the option currently displayed is the one used lastly. We shall explore more about flyouts when we come to **the sample drawing towards the end of chapter 5**.
CHAPTER 5.

5. COMMANDS

5.1. Overview and Definitions.

You communicate with AutoCAD by using tools and Menu options. These devices invoke AutoCAD commands.

5.1.1. What is a command?

It’s a single-word instruction you give to AutoCAD telling it to do something such as draw a line (the line tool in the Draw Ribbon Panel) or erase an object (the Erase tool in the Modify Ribbon Panel). Whenever you invoke a command, by either typing it or selecting a menu option or tool, AutoCAD responds by presenting messages to you in the Command Window and the Dynamic Input display or by displaying a dialogue box. By right clicking during the drawing process, a context-sensitive short cut menu is displayed; i.e. if you are in the middle of a command, this menu displays a list of options specifically related to that command.

5.1.2. Command tools.

Move the arrow cursor to the Line tool and rest it there. Do not click yet. Hold it there for a little while and then for a longer while. You will see two tool tips. The first tip gives you the tool tip name and the keyboard command associated with the tool. The second tip gives a brief explanation of how to use the tool. This happens to all other tools on the ribbon. To be able to draw effectively with AutoCAD, you must learn how to tell AutoCAD what you want, and even more important, understand what AutoCAD wants from you.

5.1.3. Methods of Accessing/Activating Commands.

i. Clicking on the command tool/icon on the Ribbon Panels.

ii. Typing the command on the Keyboard.

iii. Use of Accelerator Keys. These are special keystrokes that open and activate drop down menu options. Example is Ctrl+S for save and Ctrl+C for copy.

iv. Use ofAliases; (one, two or three letter abbreviations of a command name). These are also typed on the key board.

5.2. Draw Command Tools.

Figures (a) and (b) below are clippings of the draw commands panels from 3D modeling and 2D drafting and annotation workspaces respectively. Figure (c) is the draw tools palette from the AutoCAD Classic workspace.
As mentioned above, you can get the name and function of each simply by placing the arrow cursor on the specific tool. We head straight to the usage and execution of each.

5.2.1. The Line Command.

When using the line command, you end up with a series of contiguous line segments meaning each can be selected or highlighted individually.

1. On the Home tab ➤ Draw panel click the Line tool.
2. Specify the start point. You can use your mouse or enter coordinate values at the Command prompt.
3. Complete the first line segment by specifying the endpoint. To undo the previous line segment during the LINE command, enter u or click Undo on the toolbar.
4. Specify the endpoints of any additional line segments. Press Enter to end or c to close a series of line segments. Pressing C creates an enclosure.
5. To start a new line at the endpoint of the last line drawn, start the LINE command again and press Enter at the Specify Start Point prompt

5.2.2 The Rectangle Tool

The rectangle command enables you to create a rectangle by specifying coordinates for two corners only.

1. On the Home tab ➤ Draw panel, click the Rectangle tool.
2. Specify the first corner of the rectangle.
3. Specify the other corner of the rectangle

5.2.3. The Polyline Command

A Polyline is a connected sequence of segments created as a single object. You can create straight line segments, arc segments, or a combination of the two.
Polylines are ideal for applications including the following:

- Contour lines for topographic, isobaric, and other scientific applications
- Wiring diagrams and printed circuit board layouts
- Process and piping diagrams
- Extrusion profiles and extrusion paths for 3D solid modeling

5.2.3.1. To draw a Polyline with straight segments

i. From Home tab ➤ Draw panel click Polyline.
ii. Specify the first point of the Polyline.
iii. Specify the endpoint of the first Polyline segment.
iv. Continue specifying segment endpoints as needed.
v. Press Enter to end, or enter c to close the Polyline.

To start a new Polyline at the endpoint of the last Polyline drawn, start the PLINE command again and press Enter at the Specify Start Point prompt.

5.2.3.2. To draw a line and arc combination Polyline.

i. Click Home tab ➤ Draw panel ➤ Polyline.
ii. Specify the start point of the Polyline segment.
iii. Specify the endpoint of the Polyline segment.
iv. Switch to Arc mode by entering a (Arc) at the Command prompt.
v. Return to Line mode by entering L (Line).
vi. Specify additional Polyline segments as needed.
vi. Press Enter to end, or enter c to close the Polyline.

5.2.4. The circle command

To create circles, you can specify various combinations of center, radius, diameter, points on the circumference, and points on other objects. You can create circles in several ways. The default method is to specify the center and the radius.

5.2.4.1. To draw a circle by specifying a center point and radius or diameter

i. Do one of the following:
   - From the Home tab ➤ Draw panel ➤ Circle drop-down click Center, Radius.
   - From the Home tab ➤ Draw panel ➤ Circle drop-down click Center, Diameter.
   ii. Specify the center point.
   iii. Specify the radius or diameter.
5.2.4.2. To create a circle tangent to two objects

i. Click Home tab ➤ Draw panel ➤ Circle drop-down ➤ Tan, Tan, Radius.  

The command starts Tangent object snap mode.

ii. Select the first object to draw the circle tangent to.

iii. Select the second object to draw the circle tangent to.

iv. Specify the radius of the circle.

5.2.5. Arc command

5.2.5.1. To draw an arc by specifying three points

i. From the Home tab ➤ Draw panel ➤ Arc drop-down click 3-Point.

ii. Specify the start point.

iii. Specify a point on the arc.

iv. Specify the endpoint.

5.2.5.2. To draw an arc using a start point, a center point, and an endpoint

i. From the Home tab ➤ Draw panel ➤ Arc drop-down click Start, Center, End.

ii. Specify a start point.

iii. Specify the center point.

iv. Specify the endpoint.

5.2.6. The Polygon Tool

The Polygon tool is used to create regular polygon geometry by specifying the center point and radius of an imaginary circle, or the start point and endpoint of one of the polygon edges. Regardless of the method you choose to define the polygon, all of its sides are equal in length.

The default method for creating polygons is to specify a center point and radius. When you choose this method, you must choose either the Inscribed or Circumscribed option.

5.2.6.1. To draw a circumscribed polygon

i. From Home tab ➤ Draw panel click Polygon.

ii. At the Command prompt, enter the number of sides.

iii. Specify the center of the polygon (1).

iv. Enter c to specify a polygon circumscribed about a circle.

v. Enter the radius length (2).
5.2.6.2. To draw a polygon by specifying one edge

i. From the Home tab ➤ Draw panel click Polygon.
ii. At the Command prompt, enter the number of sides.
iii. Enter e (Edge).
iv. Specify the start point for one polygon segment.
v. Specify the endpoint of the polygon segment.

5.2.7. Spline Tool

A spline is a smooth curve that passes through or near a given set of points. The spline on the left is drawn with fit points, and the spline on the right is drawn with control vertices.

Splines are a critical tool for creating NURBS surfaces for 3D modeling. You can revolve, loft, sweep, and extrude open and closed splines to create surface objects.

5.2.7.1. To draw a spline with control vertices

i. Click Surface tab ➤ Curves panel ➤ Spline CV.
ii. Click in the drawing area to create the spline.
iii. When you are done, press Enter.

5.2.7.2. To draw a spline with fit points

i. Click Surface tab ➤ Curves panel ➤ Spline Knot.
ii. Click in the drawing area to create the spline.
iii. When you are done, press Enter.

5.2.8. Ellipse Tool

The shape of an ellipse is determined by two axes that define its length and width. The longer axis is called the major axis, and the shorter one is the minor axis.

5.2.8.2. To draw a true ellipse using endpoints and distance
i. Click Home tab ➤ Draw panel ➤ Ellipse drop-down ➤ Axis, End.
ii. Specify the first endpoint of the first axis (1).
iii. Specify the second endpoint of the first axis (2).
iv. Drag the pointing device away from the midpoint, and click to specify a distance (3) for half the length of the second axis.

5.3. MODIFY COMMANDS

5.3.1. Erase Tool.

There are many ways to delete objects from your drawing and clean up the display.

i. To remove blips, use REDRAW.
ii. To remove stray pixels, use REGEN.

5.3.1.1. To erase an object

i. From the Home tab ➤ Modify panel click Erase.
ii. At the Select Objects prompt, use a selection method to select the objects to be erased or enter an option:
   - Enter L (Last) to erase the last object drawn.
   - Enter p (Previous) to erase the last selection set.
   - Enter all to erase all objects from the drawing.
   - Enter? to see a list of all selection methods.
iii. Press Enter to end the command

5.3.2. Copy Tool

5.0.2.1. To copy an object using two points

i. Click Home tab ➤ Modify panel ➤ Copy.
ii. Select the objects to copy.
iii. Specify the base point.
iv. Specify the second point. Press Enter.

5.3.3. Mirror Tool

Mirroring is useful for creating symmetrical objects because you can quickly draw half the object and then mirror it instead of drawing the entire object.
5.3.3.1. To mirror objects in 2D

i. Click Home tab ➤ Modify panel ➤ Mirror. 
ii. Select the objects to mirror. 
iii. Specify the first point of the mirror line. 
iv. Specify the second point. 
v. Press Enter to retain the original objects, or enter y to erase them.

5.3.3.2. To mirror objects in 3D

i. Click Home tab ➤ Modify panel ➤ 3D Mirror. 
ii. Select the object to mirror. 
iii. Specify three points to define a mirroring plane. 
iv. Press Enter to retain the original objects, or enter y to delete them.

5.3.4. Offset Tool

Offset an object to create a new object whose shape parallels the shape of the original object of a selected object. Offsetting a circle or an arc creates a larger or smaller circle or arc, depending on which side you specify for the offset.

5.3.5. Array Tool.

You can create copies of objects in a rectangular or polar (circular) pattern called an array. For rectangular arrays, you control the number of rows and columns and the distance between each. For polar arrays, you control the number of copies of the object and whether the copies are rotated. To create many regularly spaced objects, arraying is faster than copying.
5.3.5.1. Creating Rectangular Arrays.

i. Click Home tab ➤ Modify panel ➤ Array.
ii. In the Array dialog box, select Rectangular Array.
iii. Click Select Objects. The Array dialog box closes. You are prompted for object selection.
iv. Select the objects to be arrayed and press Enter.
v. In the Rows and Columns boxes, enter the number of rows and columns in the array.
vi. Specify the horizontal and vertical spacing (offsets) between objects by using one of the following methods:

vii. In the Row Offset and Column Offset boxes, enter the distance between rows and between columns. Adding a plus sign (+) or a minus sign (-) determines direction.

- Click the Pick Both Offsets button to use the pointing device to specify the diagonal corners of a cell in the array. The cell determines the vertical and horizontal spacing of the rows and columns.
- Click the Pick Row Offset or Pick Column Offset button to use the pointing device to specify the horizontal and vertical spacing. The example box displays the result.
viii. To change the rotation angle of the array, enter the new angle next to Angle of Array.
ix. The default angle 0 direction setting can also be changed in UNITS.
x. Click OK to create the array.

5.3.5.2. Creating Polar Arrays.

i. Click Home tab ➤ Modify panel ➤ Array.
ii. In the Array dialog box, select Polar Array.
iii. Next to Center Point, do one of the following:

- Enter an X value and a Y value for the center point of the polar array.
- Click the Pick Center Point button. The Array dialog box closes and you are prompted for object selection. Use the pointing device to specify the center point of the polar array.
iv. Click Select Objects. The Array dialog box closes and you are prompted for object selection.
v. Select the objects to be arrayed.
vi. In the Method box, select one of the following methods:

- Total Number of Items & Angle to Fill
- Total Number of Items & Angle Between Items
- Angle to Fill & Angle Between Items
vii. Enter the number of items (including the original object), if available.
viii. Use one of the following methods:
• Enter the angle to fill and angle between items, if available. Angle to Fill specifies the distance to fill around the circumference of the array. Angle Between Items specifies the distance between each item.
• Click the Pick Angle to Fill button and the Pick Angle Between Items button. Use the pointing device to specify the angle to fill and the angle between items. The example box displays the result.

ix. You can set any of the following options:
• To rotate the objects as they are arrayed, select Rotate Items As Copied. The example area displays the result.
• To specify the X,Y base point, select More, clear the Set to Object’s Default option and enter values in the X and Y boxes, or click the Pick Base Point button and use the pointing device to specify the point.

x. Click OK to create the array.

5.3.6. Move Tool.
You can move objects at a specified distance and direction from the originals. Use coordinates, grid snap, object snaps, and other tools to move objects with precision.

5.3.6.1. To move an object using two points
i. Click Home tab ➤ Modify panel ➤ Move.
ii. Select the objects to move.
iii. Specify a base point for the move.
iv. Specify a second point. The objects you selected are moved to a new location determined by the distance and direction between the first and second points.

5.3.6.2. To move an object using a displacement
i. Click Home tab ➤ Modify panel ➤ Move.
ii. Select the object to move.
iii. Enter the displacement in the form of a Cartesian, polar, cylindrical, or spherical coordinate value. Do not include the @ sign, because a relative coordinate is assumed.
iv. At the prompt for the second point, press Enter. The coordinate values are used as a relative displacement rather than the location of a base point. The selected objects are moved to a new location determined by the relative coordinate values you enter.

5.3.7. Rotate tool
You can rotate objects in your drawing around a specified base point. To determine the angle of rotation, you can enter an angle value, drag using the cursor, or specify a reference angle to align to an absolute angle.
5.3.7.1. To rotate an object.

i. Click Home tab ➔ Modify panel ➔ Rotate.
ii. Select the object to rotate.
iii. Specify the base point for the rotation.
iv. Do one of the following:
   - Enter the angle of rotation.
   - Drag the object around its base point and specify a point location to which you want to rotate the object.
   - Enter c to create a copy of the selected objects.
   - Enter r to rotate the selected objects from a specified reference angle to an absolute angle.

5.3.7.2. To rotate a 3D object around an axis

i. Click Modify menu ➔ 3D Operations ➔ Rotate 3D.
ii. Select the object to rotate (1).
iii. Specify the start point and endpoint of the axis about which the objects are to be rotated (2 and 3). The positive axis direction is from the start point to the end point, and the rotation follows the right-hand rule.
iv. Specify the angle of rotation.

5.3.8. Trim and Extend.

You can shorten or lengthen objects to meet the edges of other objects. Objects you select as cutting edges or boundary edges are not required to intersect the object being trimmed.

5.3.8.1. To extend an object.

i. Click Home tab ➔ Modify panel ➔ Extend.
ii. Select the objects to serve as boundary edges.
iii. To select all displayed objects as potential boundary edges, press Enter without selecting any objects.
iv. Select the objects to extend.

5.3.8.2. To trim an object.

i. Click Home tab ➔ Modify panel ➔ Trim.
ii. Select the objects to serve as cutting edges. To select all displayed objects as potential cutting edges, press Enter without selecting any objects.
iii. Select the objects to trim.

5.3.9. Break and Join tools
You can break an object into two objects with or without a gap between them. You can also join objects to make a single object.

5.3.9.1. Break Objects
i. Click Home tab ➤ Modify panel ➤ Break.
ii. Select the object to break. By default, the point at which you select the object is the first break point. To select a different pair of break points, enter f (First) and specify the first break point.
iii. Specify the second break point.
iv. To break an object without creating a gap, enter @0,0 to specify the previous point.

5.3.9.2. Join Objects.
Use JOIN to combine similar objects into a single object. You can join: Arcs, Elliptical arcs, Lines, Polylines & Splines
The object to which you want to join similar objects is called a source object. Objects to be joined must be located in the same plane
i. Click Home tab ➤ Modify panel ➤ Join.
ii. Select the source object to which you want to join objects.
iii. Select one or more objects to join to the source object. Valid objects include arcs, elliptical arcs, lines, polylines, and splines. Additional restrictions for each type of objects are described in the JOIN command.

5.3.10. Fillet Tool.
A fillet connects two objects with an arc that is tangent to the objects and has a specified radius. An inside corner is called a fillet and an outside corner is called a round; you can create both using the FILLET command. You can fillet: Arcs, Circles, Ellipses and elliptical arcs, Lines, Polylines, Rays, Splines, Xlines & 3D solids.

FILLET can be used to round all corners on a Polyline using a single command.

5.3.10.1. To set the fillet radius.
i. Click Home tab ➤ Modify panel ➤ Fillet.
ii. Enter r (Radius).
iii. Enter the fillet radius
iv. Select the objects to fillet.
5.3.10.2. To fillet two line segments
i. Click Home tab ➤ Modify panel ➤ Fillet.
ii. Select the first line.
iii. Select the second line.

5.3.10.3. To fillet without trimming
i. Click Home tab ➤ Modify panel ➤ Fillet.
ii. If necessary, enter t (Trim). Enter n (No Trim).
iii. Select the objects to fillet.

5.3.10.4. To fillet an entire Polyline
i. Click Home tab ➤ Modify panel ➤ Fillet.
ii. Enter p (Polyline).
iii. Select the Polyline.
CHAPTER 6.
SAMPLE DRAWINGS.

Preview.

This chapter is designed for the following purposes:

i. Reinforce the understanding of the chapters we’ve dealt with towards this end.

ii. Induce confidence in the learner by taking him through a complete drawing session in a stepwise fashion.

iii. Introduce you to 3D beforehand so you can appreciate the connection between 2D and 3D.

6.1. SAMPLE DRAWING 1 & DIMENSIONING.

The figure below shows the plan of a simple design of a house with the different types of dimensions. The dimension styles can be selected from the dimension tab on the menu bar and their applications are as tabulated below the figure.
**Table: Dimension styles Used.**

<table>
<thead>
<tr>
<th>DIMENSION STYLE</th>
<th>PROCEDURE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Diameter/ Radius</td>
<td>Click on the <em>radius</em> or <em>diameter</em> tool.</td>
</tr>
<tr>
<td></td>
<td>Click on the circumference of the circle or on the arc</td>
</tr>
<tr>
<td></td>
<td>Drag the dimension line into position</td>
</tr>
<tr>
<td>2. Angular</td>
<td>• Click on the <em>Angular Dimension</em> tool.</td>
</tr>
<tr>
<td></td>
<td>• Click on the first line, then on the second – a curved dimension line will appear.</td>
</tr>
<tr>
<td></td>
<td>• Drag the dimension line into position.</td>
</tr>
<tr>
<td>3. Aligned</td>
<td>• Click on the <em>Aligned Dimension</em> tool.</td>
</tr>
<tr>
<td></td>
<td>• Click on one end of the line to be measured, then on the other- a dimension line will appear.</td>
</tr>
<tr>
<td></td>
<td>• Pull the dimension line outwards from the drawing and click when it is in clear space.</td>
</tr>
<tr>
<td>4. Linear</td>
<td>• Click on the <em>Linear Dimension</em> tool.</td>
</tr>
<tr>
<td></td>
<td>• Click on one end of the line to be measured, then on the other – a new line will appear.</td>
</tr>
<tr>
<td></td>
<td>• Pull the dimension line out and click when it is in clear space.</td>
</tr>
<tr>
<td>5. Leader</td>
<td>• Click on the <em>Leader</em> tool.</td>
</tr>
<tr>
<td></td>
<td>• Click on the object you want to label.</td>
</tr>
<tr>
<td></td>
<td>• Drag and click to create a line from the drawing.</td>
</tr>
<tr>
<td></td>
<td>• If a second line is required – perhaps to angle around another object – drag and click to create it.</td>
</tr>
<tr>
<td></td>
<td>• Right click to end the line – drawing part of the routine.</td>
</tr>
<tr>
<td></td>
<td>• The Command Line will prompt you to type a value or Right Click to accept the default value.</td>
</tr>
<tr>
<td></td>
<td>• To edit the leader you can double click and an editing and formatting display is prompted.</td>
</tr>
</tbody>
</table>
6.2. SETTING UP THE AUTOCAD WORK AREA.

In this section, sample drawings have been presented with a view to give you a practical experience with the commands. The following should become clear:

- Specifying distances using coordinates.
- Interpreting the cursor modes and understanding prompts.
- Selecting objects and editing with grips.
- Using the Dynamic Input.
- Getting help.
- Displaying data in a text window.
- Displaying the properties of an object.

6.2.1. Let’s draw a door

i. After you have launched AutoCAD 2011, click the **New** tool in the Quick Access toolbar. Select **acad.dwt** from the **Select Template** dialogue box and click **Open** (see figure below).

ii. If you are not yet in the 2D Drafting and Annotation workspace switch to it using the workspace switching tool (the gear wheel on the status bar). Note that in figure (a) below, in the file name slot you have the name **acad.dwt**. This is prior to clicking open.

![Fig (a): The 2D drafting and annotation workspace showing the Select Template dialogue box that pops up after clicking new from the quick access toolbar.](image)
You’ll start setting the size of the work area, known as the drawing limits. The limits can help to establish a starting area from which you can expand the drawing:

i. Click the Close icon in the upper-left corner of the drawing area to close the current file. In the Save Changes dialog box, click No. Notice that the Ribbon disappears and the AutoCAD drawing window appears blank when no drawings are open.

ii. Click New in the Quick Access toolbar to open the Select Template dialog box.

iii. Select the ACAD.DWT template, and click Open.

You have a new blank file, but it’s a little difficult to tell how big your drawing area is. Next, you’ll set up the work area so you have a better idea of the space you’re working with:

i. Type **Limits** in the command window and press Enter.

ii. At the **SPECIFY LOWER LEFT CORNER OR [ON/OFF] <0.0000, 0.0000>** prompt, press Enter.

iii. At the **SPECIFY UPPER RIGHT CORNER <12.0000, 9.0000>** Prompt type 400,300 and press Enter.

```
Command: limits
Reset Model space limits:
Specify lower left corner or [ON/OFF] <0.0000,0.0000>: 
Specify upper right corner <12.0000,9.0000>: 
```

iv. Press Z and Enter, then press A and Enter. You can also select all from the Zoom flyout on the View tab’s Navigate panel.

In the last step, the All option of the Zoom command uses the limits you set up in steps 2 and 3 to determine the display area. In a drawing that contains objects, the **Zoom tool’s All option displays the limits plus the area occupied by the objects in the drawing if they happen to fall outside the limits.** Now give your file a unique name.

i. Choose Save As from the Application menu to open the Save Drawing As dialog box.

ii. Type **Door.** As you type, the name appears in the File Name text box.

iii. Save your file in the MY DOCUMENTS folder, or if you prefer, save it in another folder of your choosing. Since this is a file you will need to modify often, you can even save it in **my designs** folder in disk D.

iv. Click Save. You now have a file called DOOR.DWG, located in **my designs** folder. Your folder contains nothing as we speak. Next you will include something.
6.2.2. Understanding the Drawing Area.

The new file shows a drawing area roughly 400 millimeters by 300 millimeters high. This area is your workspace, although you’re not limited to it in any way. No visual clues indicate the size of the area. To check the area size for yourself, move the crosshair cursor to the upper-right corner of the drawing area and observe the value in the coordinate readout in the lower-left corner. The coordinate readout won’t show exactly 400mm by 300mm, because the proportions of your drawing area aren’t likely to be exactly 400 by 300. AutoCAD tries to optimize the display for the drawing area when you choose the All option of the Zoom command.

Turn off the **dynamic input** on the status bar just to make sure it doesn’t distract you.

1. Locate the Dynamic Input tool in the status bar.
2. Click the Dynamic Input tool to turn it off. You can tell it is off when it turns a light gray color.

Now you can begin to explore the drawing process.

a) Click the Line tool on the Home tab’s Draw panel, or type **L** and press Enter. You’ve just issued the Line command. AutoCAD responds in two ways. First, you see the message **SPECIFY FIRST POINT:** in the Command prompt, asking you to select a point to begin your line. Also, the cursor changes its appearance; it no longer has a square in the crosshairs. This is a clue telling you to pick a point to start a line.

b) Using the left mouse button, select a point on the screen near the center. After you select the point, AutoCAD changes the prompt to this: **SPECIFY NEXT POINT OR [UNDO]:** Now, as you move the mouse around, notice the line with one end fixed on the point you just selected and the other end following the cursor in a **rubber-banding** motion.

c) Move the cursor to a point below and to the right of the first point you selected, and click again. You’ve just drawn a line segment.

d) If the line you drew isn’t the exact length you want, you can back up during the Line command and change it. To do this, type **U** and press Enter. The line you drew previously rubber-bands as if you hadn’t selected the second point to fix its length.

e) Right-click and select Enter. This terminates the Line command.

The Undo tool in the Quick Access toolbar offers an Undo and Redo drop-down list from which you can select the exact command you want to undo or redo.
You’ve just drawn, and then undrawn, a line of an arbitrary length. The Line command is still active. Two onscreen clues tell you that you’re in the middle of a command. If you don’t see the word COMMAND in the bottom line of the Command window, a command is still active. Also, the cursor is the plain crosshair without the box at its intersection. This is called the point selection mode of the cursor.

**Specifying Polar Coordinates**
To enter the exact distance 90 units to the right of the last point you selected, do the following:

i. Type @90<0. As you type, the letters appear at the Command prompt.

ii. Press Enter. A line appears, starting from the first point you picked and ending 90 units to the right of it. You’ve just entered a relative polar coordinate.

The “at” sign (@) you entered tells AutoCAD that the coordinate you’re specifying is from the last point you selected. The 90 is the distance, and the less-than symbol (<) tells AutoCAD that you’re designating the angle at which the line is to be drawn. The last part is the value for the angle, which in this case is 0 for 0°. This is how to use polar coordinates to communicate distances and directions to AutoCAD. Angles are given based on the system shown in Figure 2.6, in which 0° is a horizontal direction from left to right, 90° is straight up, 180° is horizontal from right to left, and so on.

iii. Assuming our door is 90 by 10. Now move the cursor vertically below the this second point until the rubber banding line is perpendicular to the first line. You may choose below or above. Type 10.

iv. Then type @90<180 and see you get a line parallel to the first

v. Either:
   - Type C and Enter. You have told AutoCAD to join the first point to the last using a straight line OR
   - Move the cursor to the first point and click.
   - If you are above the first line, move the cursor down to get a perpendicular, type 10 and Enter. If you are below the first line, do the converse.

**You have drawn the plan of a door.** Check to see whether your figure looks like the one in figure (b) below. Click save on the quick Access toolbar.
6.2.2.1. Why Use the Keyboard Commands?

AutoCAD has been designed in such a way that users at different levels of experience with it will find their own convenient way of using it. In the initial chapters it was explained that every tool on the ribbon and the quick access toolbar whenever pointed at shows tool usage tips which include the keyboard equivalents of the command tools.

Now by alternately using the tools and keyboard command entry, it is easy to know which is more convenient and faster for you. If it is the keyboard use it; if it is the tools go for them. In these initial stages of your use of AutoCAD, try to stick with the tools because they will save you unnecessary frustration.

6.2.2.2. Understanding Cursor Modes.

The **Standard cursor** tells you that AutoCAD is waiting for instructions. You can also edit objects by using grips when you see this cursor.

The **Point Selection cursor** appears whenever AutoCAD expects point input. It can also appear in conjunction with a rubber-banding line. You can either click a point or enter a coordinate through the keyboard.

The **Object Selection cursor** tells you that you must select objects

The **Snap** lets you accurately select specific points on an object, such as endpoints or midpoints.
6.2.3. Introduction to 3D.

We want to use the door we have created above to teach you how to use the following commands: region, extrude, presspull and visual styles.

i. Open your DOOR file.

ii. Switch the workspace to 3D modeling.

iii. Go to Home Tab> View panel> unsaved view. Click on the downward arrow and choose SW isometric. Your view should look the one in figure (c) below.

iv. From Home Tab> Draw panel click on the Region tool. Follow the instructions carefully. We mean select the objects first. In our case it’s the four lines of the rectangle of which you can use two methods namely:
   - All at once by enclosing them in a two point rectangular region OR
   - Individually by selecting each of the four lines separately.

v. Click Enter. You now have an enclosed region. To confirm it’s a region try highlighting one of the four lines. The entire rectangle is instead highlighted.

Fig (c): the rectangle in 3D modeling workspace, SW isometric view.

vi. Now from the Home Tab> modeling panel, click Extrude. Follow the instructions on the command prompt i.e. select the object and click Enter.

vii. At the SPECIFY HEIGHT: prompt, type 200 and click Enter.
viii. Alternatively click Presspull after step 3 above. The command prompt says CLICK INSIDE BOUNDED AREAS TO PRESS OR PULL:. Press pull requires the enclosing lines lines to be connected, but not necessarily forming a closed loop.

ix. Click Enter. Pull upwards and type in 200.

For both cases your door should appear like the one shown in figure (d) below.

Fig (d): The extruded door.

x. Now go to the Home Tab> View panel and click on the visual styles pull down. Currently the name on it is 2D wire frame. This should be clear from the fact that your door now appears only as a network of lines in 3D space.

xi. Click on the conceptual style and see how your door looks like.

xii. Now click on realistic and then try shaded. Your get different views of your door. We advise that you stick with the conceptual style. Our opinion is that it's more realistic.

Figure (e) below shows what we expect you to see.
Fig (e): The conceptual view.

Try out other shapes as well their combinations. It’s interesting.
INTRODUCTION.

As you have noticed from chapter 6, in AutoCAD 2011 the general commands for both 2D and 3D tasks are the same. This you may easily verify by inspecting the ribbons of both workspaces. However it’s very convenient that whenever you want to draw in 3D that you switch to 3D modeling work space since it offers you additional tools on the ribbon that make your work very easy and interesting.

In 3D modeling and especially when the details start becoming complex and when you want to view hidden details, the view cube at the top right corner of the drawing area will be indispensable. The view cube performs similar functions as the viewports tab of the view panel on the Home tab ribbon with the added advantage that it can be rotated along its corners, sides and faces giving you more directions of view.

It is not immediately possible to say which one between 2D and 3D drawing is superior to the other. However it’s notable that for one 3D drawing, it would take multiple views on 2D to express the same details with at least comparable clarity. Nonetheless, in most of the working drawings 2D has for long been preferred in order to provide as many views as possible (including sectional views) in order to guide the fabrication process with zero ambiguity. The good news however is that we want the people involved in fabrication to grasp the bigger picture of the components to be produced with little effort, and therefore the possibility of understanding the 2D drawings with ease.

Further, the processes of design and manufacture have lately been interfaced by the near exponential advances in the twin practices of CAD and CAM (computer aided design and computer aided manufacturing) respectively. The technology which started off as NM (numerical machining) has advanced to the point where machines are computer enabled to decode directly the data fed in the form of drawings. This is another aspect that puts 3D modeling on the surging path given that machines can produce the entire component that is fed into machine only in the form of a drawing.

In this chapter, given the introduction in the previous chapter, we will do a brief overview of the commands and their usage. The sample drawings will lead us directly to assembly drawing then we conclude. Surface and mesh modeling just be mentioned to wet your appetite. But having a footing and able to know where to look for help, we believe you can find your way through surface and mesh modeling.
7.1. MODELING.

7.1.1. Solid primitives.

Preview.

3D solid primitives are standard shapes which are provided among the ribbon options on the 3D modeling workspace. They include box, wedge, cone, cylinder, sphere, pyramid and torus. The principles of drawing them are similar.

Example. When you want to draw a box AutoCAD will first ask you to pick the first corner. After you pick it, AutoCAD asks or the second corner. Lastly it asks you for the height.

In the case of a cylinder the sequence of prompts is: specify the centre, specify the radius and lastly specify the height.

7.1.2. Extrude.

You can extrude either an open or closed object to create 3D surface or solid. If you extrude a surface, you will create a regular surface or a NURBS surface depending on how the SURFACEMODELINGMODE system variable is set. To extrude meshes, use the MESHEXTRUDE command.

7.1.3. Loft.

Creates a 3D solid or surface by specifying a series of cross sections. The cross sections define the shape of the resulting solid or surface. You must specify at least two cross sections. Loft profiles can be open or closed, planar or non-planar, and can also be edge subobjects. Use the mode option to select whether to create a surface or a solid.

7.1.4. Revolve.

Creates a 3D solid or surface by sweeping an object around an axis.

7.1.5. Sweep.

Creates a 3D solid or surface by sweeping a 2D or 3D object or subobject along a path. For example if you sweep a circle along a line, you will have drawn a pipe. If sweep the same along a spiral, you will have drawn a helical spring.

7.1.6. Presspull.

Press or pull a bounded area by clicking inside the area. Then drag or enter a value to indicate the amount of extrusion. As you move the cursor, the extrusion changes dynamically. You can press
or pull any area that is completely bounded by connected lines, arcs or even polylines. So the area you press or pull doesn’t have to be a region as in the case of extrusion.

7.1.7. Polysolid.

The POLYSOLID command provides a quick way to draw 3D walls. A polysolid is like an extruded, wide Polyline. In fact, you can draw polysolids the same way that you draw a polyline, using both straight and curved segments. Unlike extruded polylines, which lose any width properties upon extrusion, polysolids retain the width of their line segments. You can also convert objects such as a line, 2D Polyline, arc, or circle to a polysolid.

7.1.7.1. To draw a polysolid
   i. Click Home tab ➤ Modeling panel ➤ Polysolid.
   ii. Specify a start point.
   iii. Specify the next point. To create a curved segment, at the Command prompt, enter a (Arc) and specify the next point. Repeat step 3 to complete the desired solid.
   iv. Press Enter.

To create a polysolid from an existing object
   i. Click Home tab ➤ Modeling panel ➤ Polysolid.
   ii. At the Command prompt, enter o (Object).
   iii. Select a 2D object such as a line, Polyline, arc, or circle. A 3D polysolid is created using the current height and width settings. The original 2D object is deleted or retained.

7.2. 3D Operations.

7.2.1. Move.

Similar to 2D.

7.2.2. 3D Rotate.

Constrain the rotation of 3D objects and subobjects to an axis. After you select the objects and subobjects that you want to rotate, the gizmo is located at the center of the selection set. This location is indicated by the center box (or base grip) of the gizmo. It sets the base point for the movement and temporarily changes the position of the UCS while you rotate the objects.
You then rotate the objects freely by dragging outside the gizmo. You can also specify an axis about which to constrain the rotation, upon which you are free to specify the angle of rotation.

7.2.3. Align and 3D Align.
You can move, rotate, or tilt an object so that it aligns with another object.

In the following example, two pairs of points are used to align the piping in 2D using the ALIGN command. Endpoint object snaps align the pipes precisely.

In 3D, use the 3DALIGN command to specify up to three points to define the source plane followed by up to three points to define the destination plane.

- The first source point on an object, called the base point, is always moved to the first destination point.
- Specifying a second point for either the source or the destination results in the selected objects being rotated.
- A third point for either the source or the destination results in further rotation of the selected objects.

With 3D solid models, it is recommended that you turn on dynamic UCS to speed the selection of the destination plane.

7.2.5. 3D mirror.
You can mirror objects across a specified mirroring plane. The mirroring plane can be one of the following:
• The plane of a planar object.
• A plane parallel to the XY, YZ, or XZ plane of the current UCS that passes through a specified point.
• A plane defined by three specified points (2, 3, and 4).

i. Click Home tab ➤ Modify panel ➤ 3D Mirror.
ii. Select the object to mirror.
iii. Specify three points to define a mirroring plane.
iv. Press Enter to retain the original objects, or enter y to delete them.

7.2.6. 3D Array.

7.2.6.1. To create a 3D rectangular array of objects.

i. Click Home tab ➤ Modify panel ➤ 3D Array.
ii. Select the object to array (1).
iii. Specify Rectangular.
iv. Enter the number of rows.
v. Enter the number of columns.
vi. Enter the number of levels.
vii. Specify the distance between rows.
viii. Specify the distance between columns.
ix. Specify the distance between levels.

7.2.6.2. To create a 3D polar array of objects.

i. Click Home tab ➤ Modify panel ➤ 3D Array.
ii. Select the object to array (1).
iii. Specify Polar.
iv. Enter the number of items to array.
v. Specify the angle that the arrayed objects are to fill.
Press Enter to rotate the objects as they are arrayed, or enter n to retain their orientation. Specify the start point and endpoint of the axis about which the objects are to be rotated (2 and 3).

7.2.7. Slice.

Creates new 3D solids and surfaces by slicing, or dividing existing objects.

The cutting plane is defined with 2 or 3 points, by specifying a major plane of the UCS, or by selecting a surface object (but not a mesh). Either one or both sides of the sliced 3D solids can be retained.

The sliced objects retain the layer and color properties of the original solids. However, the resulting solid or surface objects do not retain a history of the original objects.

7.2.8. Thicken.

Converts a surface into a 3D solid with a specified thickness. A useful technique for modeling a complex 3D curved solid is to first create a surface and then convert it to a 3D solid by thickening it. Initially, the default thickness value is zero.

7.2.9. Convert to Solid.

If you want to convert a 2D Polyline e.g. a rectangle into a solid, you will start by giving it a thickness. Then you go to the modify panel and click the CONVERT TO SOLID BUTTON. Select the thickened object and click Enter.

7.2.9.1. To set the 3D thickness of new objects
i. Click Format menu \_\_ Thickness.
ii. At the Command prompt, enter the value for the thickness distance. When new objects are created, they have the specified 3D thickness.

7.2.10. Convert to Surface.
Converts objects to 3D surfaces. You can select the objects to convert before you start the command. Of note is that you can create 3D solids with curved faces, such as a cylinder, with the EXPLODE command.

7.2.11. Extract Edges.
Wireframe models consist only of points, lines, and curves that describe the edges of the object. Because each object that makes up a wireframe model must be independently drawn and positioned, this type of modeling can be the most time-consuming.

You can use a wireframe model to:

i. View the model from any vantage point.
ii. Generate standard orthographic and auxiliary views automatically.
iii. Generate exploded and perspective views easily.
iv. Analyze spatial relationships, including the shortest distance between corners and edges, and checking for interferences.
v. Reduce the number of prototypes required.

You can create wireframe models by positioning any 2D planar object anywhere in 3D space, using the Extract Edges command:

Use the XEDGES command to create wireframe geometry from regions, 3D solids, surfaces, and meshes. XEDGES extracts all the edges on the selected objects or subobjects. The extracted edges form a duplicate wireframe composed of 2D objects such as lines, circles, and 3D polylines.

7.3. Solid Editing.
7.3.1. Union.
Combines selected 3D solids, surfaces, or 2D regions by addition. You can combine two or more 3D solids, surfaces, or 2D regions into a single, composite 3D solid, surface, or region. You must select the same type of objects to combine i.e. surface to surface and solid to solid etc.

**Using the Union Command with Solids and Regions**
The selection set can contain objects that lie in any number of arbitrary planes. For mixed object types, selection sets are divided into subsets that are joined separately. Solids are grouped in the first subset. The first selected region and all subsequent coplanar regions are grouped in the second set, and so on.
The resulting composite solid includes the volume enclosed by all of the selected solids. Each of the resulting composite regions encloses the area of all regions in a subset.

**7.3.2. Subtract.**

Combines selected 3D solids or 2D regions by subtraction. With SUBTRACT, you can create a 3D solid by subtracting one set of existing 3D solids from another, overlapping set. You can create a 2D region object by subtracting one set of existing region objects from another, overlapping set. You can select only regions for use with this command.

Objects in the second selection set are subtracted from objects in the first selection set. A single new 3D solid, surface, or region is created.

**7.3.3. Imprint Edges.**

Add editable faces to 3D solids and surfaces by imprinting other objects, such as arcs and circles. With the IMPRINT command, you can add a new face to a 3D solid by imprinting a coplanar object that overlaps the selected face. Imprinting provides additional edges that you can modify to reshape the solid object.
For example, if a circle overlaps the face of a box, you can imprint the intersecting curves on the solid.

![Diagram of a circle imprinting on a box](image.jpg)

You can delete or retain the original object as you imprint it.

Objects that can be imprinted on 3D solids include arcs, circles, lines, 2D and 3D polylines, ellipses, splines, regions, bodies, and other 3D solids.

1. Click Home tab ➤ Solid Editing panel ➤ Edge Editing drop-down ➤ Imprint.
2. Select the 3D solid object.
3. Select a co-planar object that you want to imprint.
4. Press Enter to retain the original objects, or enter y to delete them.
5. Select additional objects to imprint or press Enter.
6. Press Enter to complete the command.

### 7.3.4. Fillet Edges.

1. Click Solid tab ➤ Solid Editing panel ➤ fillet Edge.
2. Select the edge of the solid to fillet.
3. Specify the fillet radius.
4. Select additional edges or press Enter to fillet.

### 7.3.5. Chamfer Edges.

1. Click Solid tab ➤ Solid Editing panel ➤ Chamfer Edge.
2. Select the edge of the base surface to chamfer. One of two surfaces adjacent to the selected edge is highlighted.
3. Do one of the following:
   - To select a different surface, enter n (Next).
   - To use the current surface, press Enter.
4. Specify the base surface distance. The base surface distance is measured from the selected edge to a point on the base surface. The other surface distance is measured from the selected edge to a point on the adjacent surface.
5. Specify the location of the chamfer using one of the following options.
- To specify an individual edge, select the edge.
- To select all edges around the base surface, enter L (Loop). Specify an edge.

vi. To complete the chamfer, press Enter.

7.3.6. Colour Edges.

i. Press and hold Ctrl as you click an edge on a 3D solid.
ii. If the Properties palette is not displayed, select any object. Right-click the object to display the shortcut menu. Click Properties.
iii. In the Properties palette, under General, click the Color arrow and select a color from the list. For additional color options, click Select Color to display the Select Color dialog box. Specify a color and click OK.

7.3.7. Copy Edges.

i. Click Home tab ➤ Solid Editing panel ➤ Edge Editing drop-down ➤ Copy Edges.
ii. Press Ctrl+click the edge of the face to copy.
iii. Select additional edges, if needed, and press Enter.
iv. Specify the base point of the copied edges.
v. Specify the second point of displacement to indicate the location of the copied edges.
vi. Press Enter to complete the command.

7.3.8. Extrude Faces.

i. Click Home tab ➤ Solid Editing panel ➤ Face Editing drop-down ➤ Extrude Faces.
ii. Select the face to extrude and click Enter.
iii. Specify the height of the extrusion.
iv. Press Enter.

7.3.9. Copy Faces.

v. Click Home tab ➤ Solid Editing panel ➤ Face Editing drop-down ➤ Copy Faces.
vi. Select the face to copy.
vii. Select additional faces or press Enter to copy.
viii. Specify the base point for the copy.
ix. Specify the second point of displacement and press Enter.

7.3.10. Delete Faces.

i. Click Home tab ➤ Solid Editing panel ➤ Face Editing drop-down ➤ Delete Faces.
ii. Select the face to delete. (It must be surrounded by faces that share the same plane.)
iii. Select additional faces or press Enter to delete.
iv. Press Enter to complete the command.
7.3.11. Colour Faces.

i. Press and hold Ctrl as you click a face on a 3D solid.

ii. If the Properties palette is not displayed, select any object. Right-click the object to display the shortcut menu. Click Properties.

iii. In the Properties palette, under General, click the Color arrow and select a color from the list. For additional color options, click Select Color to display the Select Color dialog box. Specify a color and click OK.

7.4. SAMPLE DRAWING AND ASSEMBLY.

Ensure you are on 3D modeling workspace SW isometric view port. This is just one option and you are not bound by it. You can choose any other isometric view depending on your convenience and preference.

We want to draw close to accurate representation of the Mechanical engineering building of the University of Nairobi. We will not do step by step exposition though, but we first give you the tips.

I. In drawing the top view of the walls, use the line command. Ensure that the relevant snaps are switched on to assist you locate your points accurately. If not yet set, right click on the OSNAP switch amongst the drawing aids on the task bar and click on settings. From the resulting dialogue box click on the object snap tab and mark or unmark the snaps of your choice. Ensure endpoint and midpoint snaps saps are marked.

Figure (a): below is the appearance of the dialogue box.
II. The length of our walls is roughly 4280 cm and the width is about 1255 cm. The thickness of our outer walls is 30 cm and the inner wall partitions roughly 20 cm.

- To create the thicknesses the offset command is very useful.
- If any of your lines are crossing trim them using the trim command. Remember when it comes to press pull, the command cannot work when there are crossing lines.
- Once you have done the line network correctly, your fourth floor plan looks like figure (b) below. Don’t mind about the dimensions.
- Your 2nd and 3rd floor plans of course will be a bit different from this but maintain the precision in the outer measurements.
III. Before you press pull, make sure that the outside rectangle, each of the inner partition rectangles and the combination of the corridor and end spaces exist as independent regions. Remember we will use the press pull tool, because we only want to extrude the region between the created regions i.e. the walls. We will in one selection using the rectangular enclosure.

If you created your regions successfully, after you press Enter, you command window should display the following message in succession:

```
Command:
Command: _region
Select objects: Specify opposite corner: 19 found
Select objects:
```

After you press Enter, the command window should inform you that you have 19 regions created.

IV. Now we go to presspull. Once you select the command, move your cursor to any wall space. This highlights all the walls.

You will notice that if your cursor is inside any of the respective regions, only that region is highlighted meaning if you execute the command in that state, you will get only one rectangular solid block. Press pull the 2\textsuperscript{nd}, 3\textsuperscript{rd} and 4\textsuperscript{th} floor walls. See that your walls resemble figure (c) below. Our walls have been extruded to a height of 300 cm.
Fig (c): the 4th floor walls extruded using the presspull command.

V. First look at the UCS icon in figure (c) above. The axes have their respective colors with red for X, green for Y and blue for Z.

Notice that in (c) the Y axis is vertical while the X and Z axes are horizontal.

Now look back at figure (b). Notice that here the UCS icon has the Z axis as the vertical axis. Now given that (c) is an extrusion of (b) how did the UCS icon change its orientation?

Before we say how, it is worth understanding that if you would like to have fewer problems during the assembly stage, make sure that your components are set in the same UCS.

In (b) the UCS is the default User Coordinate System called the World Coordinate System. To define your own coordinate system, follow the following steps:

- Click the view tab on the menu bar.
- On the resulting ribbon, go to the coordinates panel and click on the Named UCS tool.
- On the dialogue box that emerges, click on the Orthographic UCSs tab.
- You can choose any of the options. But for now, click on front then click on the Set Current box to the side. Then Click ok.
- You have defined your own UCS called front in SW isometric.
• If you wish you can save this amongst your workspaces and recall it any other time you would like to use it.

**Fig (d):** The Named UCSs dialogue box.

Ensure that the walls of your three floors are all defined in the same UCS.

**VI.** To define a new origin point, go to the same view tab and to the coordinates panel once again. Click on the **Origin Tool**. Then with your cursor, move to the lower left corner on your 3D drawing and Click. Your UCS icon moves to the clicked point. Do the same for the slabs.

**VII.** Now we move to assemble our walls and slabs. We both understand that we want the 3\textsuperscript{rd} floor on top of 2\textsuperscript{nd} floor and the 4\textsuperscript{th} floor on top of 3\textsuperscript{rd}. Let’s not forget we will need the slab between the floors.
Therefore we can move the 3rd floor drawing into the 2nd floor file or vice versa and then use the Move tool to place the 3rd floor on top of the 2nd floor. We do the same for the slab. Here is how to do it:

- First open both the 2nd floor and 3rd floor tiles.
- Go to the View tab> windows panel and click on tiles vertically. Your tiles should appear as in figure (e), below.

**Fig (e):** walls ready for assembly.

**VIII.** Click on the 3rd floor to highlight it. Then click on it and hold down your mouse button until the cursor turns into an arrow with a square at the tail. In this mode your 3rd floor is ready to be dragged into the 2nd floor file. Drag it now and drop it in the 2nd floor file. Don’t mind about alignment at this stage because you will just use the move tool for that purpose.

Now close the 3rd floor file. Open the slab file and repeat the tiles vertically operation. Close the slab file and repeat the tiles vertically with the fourth floor.

**IX.** If you need several slabs just use the copy tool. Now that you have the parts needed to complete your building assembly, use the move tool to move them to their respective positions. Be sure your **Endpoint snap** is on. This will assist you in positioning your parts precisely.

Above all use the **Orbit tool** to gain a better view of the placement positions in order to eliminate errors due to parallax.

**X.** See whether your final view resembles figure (f) below. Don’t mind the colors. The colors have been assigned through the use of the layers panel which is explained in number 11 right here below.
Fig (f): The complete 3D assembly.

XI. You define layers by clicking on the Layer properties button from the Layers panel on Home Tab Ribbon. In our case we defined the 2nd, 3rd and 4th floor and the slab as shown in figure (g) and (h) respectively. Using the layers panel, we were able to assign colours to each of our layers.

You create a new layer by clicking on the New Layer Button at the top to the left of the Layer Properties dialogue box.

For each new layer, you assign your desired properties including the line type and colour among others. You assign a part to a layer by first clicking on the part and then assigning the respective layer. That part picks up the properties designed in that layer.
7.3.20. Layers

Fig (g): Layer properties dialogue box.

Fig (h): The layers used for figure (f).
<table>
<thead>
<tr>
<th>S.</th>
<th>Name</th>
<th>O.</th>
<th>Freq</th>
<th>L.</th>
<th>Color</th>
<th>Linetype</th>
<th>Lineweight</th>
<th>Trans.</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2nd floor</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3rd floor</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4th floor</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>slabs</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

All: 5 layers displayed of 5 total layers
CHAPTER 8.

MESH AND SURFACE MODELING

8.1. EXPLORING 3D MESH

AutoCAD users can construct fairly complex 3D models by use of the tools offered. With the introduction of the latest surface modeling tools, very organic forms can be modeled. But there are some types of forms that require a type of modeling known as mesh modeling. Mesh modeling enables you to create smooth, curved volumes by manipulating faces that make up an object’s surface. With mesh modeling, the user can quickly create curved shapes that are difficult or even impossible to create by other means. AutoCAD also offers the ability to convert a mesh model into a 3D solid so that you can perform Boolean operations and normal solid editing.

8.1.1. Creating a simple mesh

As an introduction to the mesh modeling features in AutoCAD, you’ll draw a simple box and then smooth the box, an exercise that will show you some of the basic mesh modeling tools. First make sure you are in the 3D Modeling workspace and that you have a blank drawing set up for the mesh. Then follow these steps:

i. Click the Workspace Switching option in the status bar and select 3D Modeling.

ii. Next, open a new file using the ACAD3D.DWT template. Click the New tool from the Quick Access toolbar.

iii. At the Select Template dialog box, select the ACAD3D.DWT template and then click Open.

8.1.2. Creating a mesh primitive

Meshes are similar to solids in that they start from what is called a primitive. 3D solid primitives are predetermined shapes from which you can form more complex shapes. You can see the different mesh primitives that are available by clicking the Mesh fly-out in the Primitives panel as shown below
Now we will consider using the Mesh Box primitive to start a cushion.
In the Mesh Modeling tab’s Primitives panel, click the Mesh Box tool, or type \textbf{Mesh} B
i. At the SPECIFY FIRST CORNER OR [CENTER]: prompt, enter 0,0 to start the mesh at the drawing origin.
ii. You’ll want a mesh that is 21 inches in the X axis by 32 inches in the Y axis, so at the SPECIFY OTHER CORNER OR [CUBE/LENGTH]: prompt, enter 21,32.
iii. At the SPECIFY HEIGHT OR [2POINT]: prompt, enter 4 for a 4-inch height. You now have iv. A basic shape for your mesh.

![Mesh Box](image)

You have just created a mesh box, but you have several other mesh primitives at your disposal. If you click the Mesh fly-out on the Modeling panel, you will see the Cylinder, Cone, Sphere, Pyramid, Wedge, and Torus primitives. When creating your model, consider which of these primitives will best suit your needs.

8.1.3. Smoothing a mesh
To help you select different sub-objects on a mesh, the Sub-object panel offers the Filter fly-out, which shows the \textbf{No Filter} tool by default.

8.1.3.1. Smoothening a mesh
One of the main features of a mesh is its ability to become a smooth, curved object. Right now your cushion has sharp edges, but you can round the corners using the Smooth tools.

Try modifying the mesh to smooth its corners:
i. Click the rectangular mesh to select it.
ii. Click the Smooth More tool in the Mesh panel or type `Meshsmoothmore`\(^4\). The edges of the mesh become faceted and smoother in appearance.
iii. Click Smooth More again. The mesh becomes smoother still.
iv. Now click Smooth Less or type `Meshsmoothless`\(^4\). The mesh becomes less smooth.
v. Press Esc to clear the selection.

From this example, you can smooth a mesh using the Smooth More tool. The fewer the faces, the broader the application of smoothness. When you apply the Smooth More tool to a mesh, the faces of the mesh become facetted. This simulates the smooth appearance. If you look closely at a mesh that has only one or two levels of smoothing applied, you can see the facets.

From the available primitives, other complex designs can be developed using the mesh and edited accordingly using the mesh commands and tools offered. These include; Stretching Faces, Fine-Tune the Mesh, Moving an Edge, Adding more Faces, Adding a Crease, Creating Mesh surfaces just to mention a few. The tools are as shown on the ribbon below.

The Mesh can then be converted to solid or surface depending on what the user wants to achieve using the “Convert to Solid” or “Convert to Surface” command.
8.2. CREATING 3D SURFACES

The user can also utilize the “Surface” option in 3D Modeling as shown below on the ribbon to create surfaces.

The surfaces created can then be edited accordingly using the surface modeling commands and tools offered including; Sweep, Revolve, Fillet, Extend, Sculpt, Blend, Trim, Untrim, Auto Trim, Convert to NURBS just to mention a few

8.2.1. Converting the Surface into a Solid.

The surfaces created can also be converted to solids as below

i. Click the Thicken tool in the Home tab’s Solid Editing panel.

![Thicken Tool](image)

You can also enter Thicken at the Command prompt.

ii. Select the surface and press Enter to finish your selection.

iii. SPECIFY THICKNESS

The surface appears to lose its webbing, but it has just been converted to a very thin 3D solid.
CHAPTER 9.

PRINTING AND PLOTTING.

There two ways which in you can print any of the drawings in AutoCAD; Using plotting or layouts. We will use our sample drawing still through this process for easy understanding.

9.1. Plotting
Ensure you are viewing the figure appropriately either in 2D design or 3D design.

i. Select File then Plot
A dialogue plot dialogue box should appear as shown below

A plot dialogue box should appear as shown below
ii. Select appropriate printer/plotter and paper size. For this example we will select “DWG To PDF.pc3”. Select on the plot area display pick window and choose the entire drawing which you want to be printed

Select center the plot

iii. Select on the top right corner for the plot style table(pen) pick Monochromatic.ctb which ensures all the layers in the drawing when being printed will be black.
iv. Select apply to all the layouts, then select yes when prompted

v. Now choose appropriate scale and do not choose fit to paper because the drawing in AutoCAD can range for different scales.

vi. Check the preview until you’re satisfied. Then select Ok to print out the document. As shown below
9.2. Layout Printing

i. There is a tab next to the model space for layout, click on it. The drawing simultaneously appears on the layout that you have selected. Now right click on it and choose page setup.

![Page Setup Manager](image1)

ii. Select on the Modify Tab. It should lead you to the dialogue box below.

![Page Setup - Layout1](image2)

The dialogue box that appears is similar to the plot mode. Now following the same procedure should lead you to the same print output.
APPENDIX 2.

SAMPLE DRAWINGS IN 3D.
(a) – Bracket 1
(b) – Mounting Block
(c) – Bracket 2
(d) – Caster wheels
(e) – Mechanical Engineering building model
(f) and (g) – Hospital bed models
(h) – Pipe wrench